WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Regenerate Thumbnails] Not adding unmatched media

[Plugin: Regenerate Thumbnails] Not adding unmatched media

  • I’ve added another image size (add_image_size) and using this plugin, generated thumbnails for pasta posts as well. I’ve tried the plugin locally and it works like a charm.

    Nevertheless, it doesn’t work on a live site. The images are generated but they aren’t linked (i.e. they should appear as unattached images in the media manager, right?!). Please help!

    http://wordpress.org/extend/plugins/regenerate-thumbnails/

Viewing 7 replies - 1 through 7 (of 7 total)
  • You should notice no difference in the media manager because you’re just creating new thumbnail sizes of existing images. The media manager shows images you have uploaded, not all of their thumbnails.

    That’s werid, since it happened on both occasions. Heres what I did:

    1. installed and ran Auto Post Thumbnail
    2. addedd add_image_size( 'loop-thumbnail', 83, 83, true ); tio my functions.php
    3. addedd the_post_thumbnail( 'loop-thumbnail', array( 'class' => "loop-thumbnail", 'title' => trim(get_the_title()) )); to my loop
    4. installed and ran Regenerate Thumbnails – which created the files correctly

    Thing is, I’ve uploaded the generated images to my live site, before running RT there. It output unknown error for all of them (identified only by ID, not name). Since the thumbs weren’t working, I deleted the 83×83 files and ran RT again. This time, it created the thumbs and added them as unattached images in the media library. Wasn’t showing up in the loop though.

    Please note, unattached images in media library is a known issue in my plugin (Auto Post Thumbnail). I will be releasing a bug fix version tomorrow, Dec 1, 2010 which addressed this issue.

    thanks adityamooley, so that explains one thing.

    So is there a problem with how I display the thumbnails? This outputs the image how it was inserted in the post:
    the_post_thumbnail( 'loop-thumbnail', array( 'class' => "loop-thumbnail", 'title' => trim(get_the_title()) ));

    However, this works properly (with set_post_thumbnail_size( 150, 150, true ); ):
    the_post_thumbnail( 'thumbnail', array( 'class' => "loop-thumbnail", 'title' => trim(get_the_title()) ));

    What gives?

    Update:
    Live site is here: http://www.fishingtonpost.ro/

    Another update. For new posts, the correct size is output. For older ones, the full size image is displayed. This after updating Auto Post Thumbnail and running it again.

    However this added the 83×83 images to the media Library, this time attached to the corresponding posts.

    Regenerating the thumbnails doesn’t fix the situation.

    I ran into a similar problem and did the following:

    Logged into phpMyAdmin and deleted all of my post_thumbnail associations in the database using the following:

    DELETE FROM wp_postmeta WHERE meta_key = '_thumbnail_id';

    Put the following two lines in my functions.php file:

    add_theme_support( 'post-thumbnails' );
    add_image_size( 'search-thumb', 80, 80, true );

    Then I reran the following commands:
    “Regenerate All Thumbnails” and “Generate Post Thumbnails”

    Now I can use the following in the loop:

    the_post_thumbnail('search-thumb');

    Ok, will try that one too, thanks 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Regenerate Thumbnails] Not adding unmatched media’ is closed to new replies.