Regenerate Thumbnails
Error while generating thumbnails for some files (12 posts)

  1. mehulved
    Posted 4 years ago #

    I see following error while generating thumbnails for some images
    function (){if(!d){var c=arguments,g,h,i,j,k;b&&(k=b,b=0);for(g=0,h=c.length;g
    It gives no idea as to what the problem is. And these re-sized images show up as corrupted even though the original one is fine.


  2. Jen Baumann
    Posted 4 years ago #

    I'm seeing this on any unattached images.

  3. cwulff
    Posted 4 years ago #

    Same thing here. Mine's happening regardless of whether it's attached or unattached. I can't find any logic to it. 69 regenerated, 66 not. I attached some of them to see if it changed, but it didn't.

  4. Alex Mills (Viper007Bond)
    Plugin Author

    Posted 4 years ago #

  5. rjksn
    Posted 4 years ago #

    Was this ever solved? I just got it on 239/240 images

    (WP 3.3 Regenerate Thumbnails 2.2.0)

  6. mehulved
    Posted 4 years ago #

    Not solved, to the best of my knowledge.

  7. ,
    Posted 4 years ago #

    Got it myself as well, testing it in a local environment.

    It looks like it was just a plain permissions problem. The images had to be executable (+x) by the webserver user.

  8. Gustavo Straube
    Posted 4 years ago #

    I modified images permission via FTP to make them executable and the error remains.

  9. Eric McNiece
    Posted 4 years ago #

    Getting this too. New install on a different server.. client wanted it on their own box, but there's so many problems...

    NextGen gallery is having a ton of trouble too, with image uploading and resize. I also can't use Advanced Custom Fields to attach images to posts. This server uses the mysqli extension instead of the usual mysql, but I suspect that there's PHP modules missing from the installation.

  10. cwulff
    Posted 4 years ago #

    I got it fixed not as a 'permissions' issue, but as an 'owner' issue in Apache.

    The files and folders had been reset to apache as owner and I needed to change them back to my user in the file manager.

  11. Eric McNiece
    Posted 4 years ago #

    NICE, that could totally be it. Damn shame that I don't have shell to the server though.

  12. beneberle
    Posted 3 years ago #

    Yep, it was permissions for me. Check your uploads directory and image files.
    The file owner should be you,
    group should be apache, www, or your webserver default,
    Permissions should be rwxrwxr-x or 664

    No shell? Contact support or find a host that offers it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Regenerate Thumbnails
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic