Support » Plugin: Redirection » [Plugin: Redirection] Some redirects working, some not

  • I’m using regular expressions to ensure that the trailing slash doesn’t matter.

    The first few I setup work fine, but about 70+ of the later ones I added don’t work and instead shows the 404 page (the URL does not change).

    For example, this one redirects perfectly:

    As does:

    ^​/booklet-template[​/]?$ does not.

    When we create them, we’re using the “URL Only” match and “Redirect to URL” value.

    I looked in the database and the early ones I added have a “NULL” value in the “title” field and some of them have a slash at the beginning of the destination URL (some are /path-here/ while others are just path-here/). I tried adjusting both of those values manually in the table and it still doesn’t work. Also tried entering them both ways in WordPress and it doesn’t make a difference.

    I’ve tested my regular expression and it seems like it should be working. However, I’m definitely not a regular expression expert so it could be an issue with that.

    One thing to note: Many of the redirect paths I am trying to redirect are similar. So, for example, I might have ^​/booklet-template[​/]?$ and then ^​/booklet-printing[​/]?$ and ^​/booklet-shopping​/]?$. I’m wondering if it’s possible the plugin gets “confused” about which rule to use?

    I’ve checked the error logs and the ones that don’t work are registering as 404s, but there’s no destination URL listed, which seems to indicating that it’s not even attempting to redirect.

    Based on another post here, I’ve checked that each redirection item has a unique “position” value and they all do. I’ve also confirmed all of them have the value of “1” for “regexp.”

    I’ve tried deactivating and reactivating the plugin as well as deactivating and reactivating the redirect items that don’t work.

    I am running SEO Ultimate on this site, so not sure if it could be interfering.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Just noticed that if you open the database as a CSV, the redirect items that aren’t working appear to be malformed with some â and characters in them:


    No idea where they are coming from…

    michaelphill – Did taking out the strange characters work? I’m having some of the same issues.

    It did. But, when entering them through the WP admin interface those weird characters always got added. It’s kind of a pain because they’re only visible when you export as a CSV. It seems that manually entering them either through phpMyAdmin or the CSV does fix the problem, but it’s kind of pain and negates the whole idea of a plugin.

    I ended up switching to “Quick Page/Post Redirect Plugin” and using its “Quick Redirects” feature instead:

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Redirection] Some redirects working, some not’ is closed to new replies.