WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [Plugin: Recent Facebook Posts] Its connected but does NOT display my FB posts?

[Resolved] [Plugin: Recent Facebook Posts] Its connected but does NOT display my FB posts?

  • SkyBerlin

    @skyberlin

    Hi,

    A great Plugin!

    But I feel blind sighted. BUT why does the widget of the Plugin “Recent FB Pages” NOT display my recent Fan FB Page Posts? Instead it displays the “default” posts of the developer…

    I feel quite stupid after setting up all the API, key and all successfully.

    Thank you for advice.

    Sky

    http://wordpress.org/extend/plugins/recent-facebook-posts/

Viewing 15 replies - 16 through 30 (of 46 total)
  • Set to 0777 and still same result.
    Sure I get error if I use faulty fb-id.
    Don’t know what more to try

    Hi JRoest,

    What is the exact problem? Is the widget showing posts from my facebook page instead of yours or …?

    Make sure all your configuration settings are correct and then try renewing your access token followed by manually emptying the cache (by hitting the button).

    I will release another update later this week with more configuration checks to further ease the process of configuring.

    Danny, to my knowledge I’ve done the settings in FB and in the widget as per your instructions. At first I had your postings until I changed it to my FB-ID. After that I’ve done the deleting and changing of permission to 0777 and clearing cache…but still I get “No recent Facebook status updates to show.” I am connected to my FB-ID according to the widget.

    One question Danny. I have my blogg/widget in a subdomain. Anything about this that might be the fault especially in the FB settings?

    Yes, but it should actually show as an error message on FB Recent Posts options screen.

    In your Facebook Developer App Settings, make sure you add your domain to the App Domains list under “Basic Info”. For example, adding “dannyvankooten.com” to the list will enable using the Facebook API for *.dannyvankooten.com (all subdomains).

    Hope that helps and fixes the problem. When I have more time I’ll investigate why it doesn’t show an error message..

    I’ve made sure everything is set properly but still the same result.

    Hi! I had the same problem and it worked after I put the PAGE-ID instead of page name into the field (I’m getting entries from a page)…
    Maybe that helps someone….

    Hi wearitwell. I’ve tried that too but it gives me the same result. I wonder if running FB under https (secure) and not http can have anything to do with it not working?

    Danny, I’m once again trying various settings and stuff to see if I can get this to work. I also went to http://wpdemo.dannyvankooten.com/ and found that your demosite too displayed “No recent Facebook status updates to show.” Just wanted you to know 🙂

    Hi JRoest.

    Thanks for pointing that out, it was because I tested fetching posts from a group page yesterday. Didn’t revert it.

    Running Facebook under https doesn’t make a difference because the plugin fetches posts from Facebook by making a call from your server, it has nothing to do with you surfing Facebook. 😉

    JRoest, could you send me a screenshot of your Recent Facebook Posts configuration settings? I will test a bit and figure out where things go wrong.

    Here are 2 pics Danny.
    Some swedish in the text but I think you’ll understand 🙂

    http://blogg.roest.se/pic1.jpg
    http://blogg.roest.se/pic2.jpg

    I’ll send you the pics with all info to your mail in a minute.
    Just realized you wanted the full info 😉

    Hi Johnny,

    Just emailed you but posting it here also because it might help others having the same problem. Your posts were not visible to the plugin because they were not publicly visibile. The plugin acts as a “logged out” facebook user, or atleast as someone who is not your friend, and can thus only see public status updates.

    Hope that helps!

    Danny

    Hi Danny and thanks for the help. I should have figured that out myself really. I have made some postings on FB public and deleted the cash and all the other steps. But no postings are showing yet. Maybe it has to do with the servers for FB. Need some time before it takes effect? I’ll see tomorrow when I’m at the computer again. You have my settings if you feel like testing to see if the postings show when you try.

    Thanks

    Johnny

    Hi Johnny,

    Hmm, tested it on my personal Facebook profile and it looks like FB’s servers don’t need any time before the changes take effect.

    Still, when visiting your FB profile I see your publicly visible posts. When looking at your profile through Facebooks Graph API, I don’t. You can have a look yourself here. Might be a bit technical but it should help you get the idea. So something on FB’s side is still going wrong. I don’t have any more time right now but will have another look later this week.

Viewing 15 replies - 16 through 30 (of 46 total)
  • The topic ‘[Resolved] [Plugin: Recent Facebook Posts] Its connected but does NOT display my FB posts?’ is closed to new replies.