Support » Fixing WordPress » [Plugin: Recent Facebook Posts] Its connected but does NOT display my FB posts?

Viewing 15 replies - 1 through 15 (of 46 total)
  • Try refreshing the cache in the Recent Facebook Posts settings – or you’ll probably notice that it has magically fixed itself after 30 minutes as the cache automatically refreshes after this time.

    Thank you MrOffice for your quick reply! 🙂

    I did refresh the “recent FB Posts” Cache under settings already few times before and also tried FF, Chrome, and Safari by also renewing their cash. The problem remains…
    http://www.lowcarb-lover.net/

    Any idea what I do wrong?!

    Thank you very much.
    Sky.

    Hey Sky.

    MrOffice his suggestion should work if you filled in the right Facebook ID in the “Facebook user id, page id or slug” field. It defaults to “DannyvanKootenCOM” which is my Facebook page. After changing the username, clear the cache (by using the “Renew Cache” button) and you should be fine.

    Let me know!

    Hi Danny!
    Thank you for getting back to me about my question! 🙂

    I think I did double check and again double checked this before – looking for typos etc. but still I don’t get my posts loaded.
    I uploaded two screenshots of the “Settings in WP” and Setting of APP in FB” maybe that helps to localize the what I dont get right?!

    01 / https://dl.dropbox.com/u/10115441/RecentFBPosts_01.jpg
    02 / https://dl.dropbox.com/u/10115441/RecentFBPosts_02.jpg

    Thank you so much for your support!
    Sky.

    Hi Sky.

    Thanks for the screenshots, they help a lot. Just tested things with your Facebook page, works fine for me. So it looks like the problem is not on your side but in the plugin. Or maybe the server settings..

    Do you have FTP access to your server? Try manually deleting /wp-content/recent-facebook-posts/cache/posts.cache. I will update the plugin to create files with the appropriate permissions in the future, overriding server defaults. If I’m right that should fix your problem.

    I’ll let you know!

    Hi Danny,

    Thank you so much!

    Yes I have FTP (Shell) and FTP Client Access.
    This is what I tried:

    1. I renamed “posts.cache” to “postsALT.cacheALT” to make it not functioning
    Error in widget: “No recent Facebook status updates to show. Did you configure the plugin properly? (only admins see this sentence)”

    2. I deleted the intire content of the file “posts.cache” (wich I think I shouldn’t do or?) Widget output: Wired Error message

    3. I did try setting 0777 and 0755 for “posts.cache”.
    All the other directories are on 0755. No result.

    Somehow it just does not renew the cache… because I can see all your settings in the posts.cache file.

    Did I do what you ment to solve it?

    Thank you. 🙂

    Sky.

    Hey Sky,

    Thanks for your extensive actions description. If that didn’t work I was wrong. I will update the plugin with a ‘debug’ option which will most likely show the error message.

    It looks like the plugin isn’t fetching from Facebook after all, it just uses the default .cache-file which I included in the plugin files by accident.

    I’m sure you tried this already but if not, please try renewing your access token? I will try to update the plugin today so we can look at this in detail.

    Danny

    Hi Danny!

    It works!!! Viola! Actually not sure what exactly was the problem still 😉
    Because I tried those steps before…

    1. I did set the directory right of “cache” again to 0777
    2. Deleted again the “posts.cache file”
    3. Renewed the “token”
    4. Updated the “cache”
    5. Works! 🙂

    I will close the topic now. Thank you again for this great plugin and your great help!

    Sky.

    I am having the same problem as SkyBerlin. I have connected FB properly, and I was getting the default fb feed.

    I went into my FTP file and deleted the /wp-content/recent-facebook-posts/cache/posts.cache but now I am getting the Error in widget: “No recent Facebook status updates to show. Did you configure the plugin properly? (only admins see this sentence)”

    I have renewed the token and updated the cache, but it is still showing the error message.

    Please help!

    Hey AWC,

    I’m having a few busy days but I will update the plugin with a debug option so you can see what is failing in the background. That should help identifying what is going wrong…

    Please give me a few days to look into this.

    Cheers, Danny.

    Same message as awc1505

    Ive tried the 4 steps mentioned by SkyBerlin, but same message
    Please Help!

    Hey awc1505 and dent555,

    Please update to version 1.0.1 and see what error message pops up in your Recent Facebook Posts options screen.

    Hi
    I’m having the same problems and still do. No errors showing after update to v 1.0.1

    Hi JRoest and dent555,

    If its not “writable” the Update should give you an error message.
    (At least it did it for me after I updated)

    Also maybe try to set the file “posts.cache” on your FTP Webserver manually to 0777.

    For me all works. 🙂 Thank you Danny!

    Sky

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘[Plugin: Recent Facebook Posts] Its connected but does NOT display my FB posts?’ is closed to new replies.