Really Static
How to Enable Comment function on the html post? (3 posts)

  1. wp999
    Posted 4 years ago #

    Hello all
    I am using really-static, and I want to enable the comment function on the html posts, have tried the Disqus Comment Plugin, but it is too slow, any other way to enable the comment function?
    I also installed this Commentredirector, http://www.sorben.org/really-static/de/plugin-commentredirector.html, but when I clicked the button "copy template from wordpress to staticfolder", there was a error like below:
    Fatal error: Call to undefined function rs_writefilewithlogin() in /XXXXX/wp-content/plugins/templatecopy/templatecopy.php on line 37

    any help?


  2. sergiomolinam
    Posted 4 years ago #

    Same steps than me, and unfortunately, same results.

    Let me try to help you.

    I guess you have wordpress on dinamic.domain.com and the destination directory of Really Static is static.domain.com. Same folders are in the same server.

    Try to do a symbolic link from static.domain.com/wp-comment-post.php to dinamic.domain.com/wp-comment-post.php

    Be sure symbolic links are enabled on htaccess of static.domain.com adding this:

    # enable symbolic links
    Options +FollowSymLinks

    If I am not wrong, that should works with any theme, but in my case it doesn't work. I need help too.

    Thanks in advance.

  3. sergiomolinam
    Posted 4 years ago #

    Hello. I achieved it!

    I don't know the specific error, but I tried changing the simbolic link mentioned above. First I had the symbolic link using complete paths:

    ln -s /home/user/dinamic.domain.com/wp-comments-post.php /home/user/static.domain.com/wp-comments-post.php

    That didn't work. But changing the paths to relative (from the folder with the static content):

    ln -s ../dinamic.domain.com/wp-comments-post.php

    It worked! I am not sure about the solution, or if this is your problem.

    Another thing: try activating or deactivating "Rewrite http://dinamic.domain.com/ with http://static.domain.com (more secure)". In my case only works with that option deactivated, but still doing tests.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Really Static
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic