Really Simple CAPTCHA
[resolved] WP 3.4 Fatal Error (8 posts)

  1. smittysmitty
    Posted 3 years ago #

    Have had great luck with this plug-in on WP 3.3, but I am now using WP 3.4. I cannot activate the plug-in. I receive this error:

    Fatal error: Cannot redeclare class ReallySimpleCaptcha in /home/cluster1/data/h/t/...wp-content/plugins/really-simple-captcha/really-simple-captcha.php on line 28

    Can I fix, or do I need to wait until the plug-in is fully compatible with WP 3.4?

    Please advise. Thanks! -A-


  2. Takayuki Miyoshi
    Plugin Author

    Posted 3 years ago #

    The error means ReallySimpleCaptcha class has already been declared and you can't declare it twice. Make sure that you have installed the plugin correctly and don't have other plugins or theme those wrongly use ReallySimpleCaptcha class inside them. Normally Really Simple CAPTCHA works with WP 3.4 without any problems.

  3. smittysmitty
    Posted 3 years ago #

    Thanks for your note. Investigating.

  4. pauly29
    Posted 3 years ago #

    My solution:

    Go to plugins, find the Really Simple Captcha plugin and click on edit. Find the very first line of the code which starts with:

    class ReallySimpleCaptcha

    Simply rename ReallySimpleCaptcha to anything you want because I think there's a conflict with the function which follows (has the same name). I just omitted an "l" in the word Really...

    Now activate the plugin...problem solved. I tested the plugin numerous times and it now works just fine.

    I'm using the same plugin on another site and didn't have this problem. Perhaps because I'm using a different theme, not sure.

    Anyway, that's it. Good luck.

  5. smittysmitty
    Posted 3 years ago #

    pauly29 - thanks for the follow up. I will give this a try.

  6. Andy
    Posted 3 years ago #

    I tried pauly29 solution several times and that solutions allows activation of the plugin without the plugins page going to blanks. However, after I create the simple code for the CAPTCHA fields, it gives an error on the actual created form page that states CAPTCHA is not installed.

    I am running 3.4.2. I suppose we'll need to wait a bit. Just let us know and thanks!

  7. Debby
    Posted 2 years ago #

    I tried pauly29's solution, and everything seems to be working perfectly now! THANKS!

  8. zimrock
    Posted 2 years ago #

    i am using wp 3.5.1 and rs captcha 1.6 and had the same issue, the fix pauly29 suggested did work for me, but will it stop working each time an automatic update is applied to the plugin? can we get a permanent solution? thanks...

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Really Simple CAPTCHA
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic