Support » Plugin: Really Simple CAPTCHA » [Plugin: Really Simple CAPTCHA] Submit Appears to Be Timing Out But It's Really Working

  • The captcha is working fine, but after a user hits ‘submit’ on our form, the spinning arrows come up beside the captcha and stay there indefinitely. The user never gets the ‘your form has been submitted’ message even though it came through to us by email in a matter of seconds. I’m using Contact Form 7 for my forms, and didn’t have this issue at all until after I installed the captcha plugin. Any suggestions?

    Here’s a link to the page if you want to try it: http://www.commetrex.com/contact/

    http://wordpress.org/extend/plugins/really-simple-captcha/

Viewing 15 replies - 1 through 15 (of 22 total)
  • I am getting the same thing tonight. Newest plugin version, newest CF7, and WP 3.4.2. All fresh downloads.

    Any insights how to fix this???

    The same thing is happening to me too. I’m using the newest CF7 and WP 3.4.2 as well. The submissions work, but the arrows spin indefinitely – and there is no confirmation that ever appears. If I remove the captcha, the form works fine.

    Edit:
    I just saw that the plugin author made the following recommendation:

    This is most probably due to a conflict between plugins/theme. Try deactivating all other plugins and switching to the default theme.

    So I disabled all my plugins except CF7 & Really Simple Captcha, I also switched to the default theme, but the same problem continued to happen.

    I reverted back to 1.4 per another suggestion and it works fine now. Thanks!

    http://wordpress.org/extend/plugins/really-simple-captcha/developers/

    I didn’t got those trouble, but i’m still at Version 3.1 😉

    But by the way: i hate this lousy readable CAPTCHA stuff and didn’t understand why the script aren’t simply check the time between load and send – i.m.h.o. it is enough protection-potential in there to figured out what messages are from Bots (because the full-fill all fields in milliseconds)?!

    But until your captcha didn’t work, why you are not working with the quiz-feature and define your own questions like this:

    <h2>Bot protection</h2>
    <p class="secure">please calculate or answer those simple questions - just to go sure that a human sender wrotes:</p><p class="quiz">[quiz random-capital-quiz 3/ id:qatest
                            "2+3 are |5"
                            "3 times a 3 results |9"
                            "17 minus 8 should be ... |12"
                            "how often is 1 in 3 |3"
                            "4 x 25  is |100"
                            "how many 5 found in 20 |4"
                            "6 Sisters playing with 3 neighbors. How many children play |9"
                            "half of 100 Meters are |50"
                            "how many drivers a bike can have |1"
                            "radical of 9  is |3"
    ]<div class="knopf">[submit "Send"]</div>

    … and place it before (or better instead of) sour Send-Button and after your last input field.

    Just as an nice hint how to handle it in a fast and small manner

    Hi Guys,

    I am having similar problem and I am not using captcha at all on my site… I have the contact form e.g. here http://newzealand.sk/studium/univerzity-na-novom-zelande/university-of-auckland/ and the wheel keeps spinning all the time.

    I have tried everything I could, disabling plugins, changing theme etc, nothing has worked. Any suggestions?

    Contact Form 7 with Really Simple Captcha is GREAT! However, Contact Form 7, version 3.3.1 + Really Simple Captcha version 1.5 give me the same problem as mltroup:

    After you hit ‘submit’, the spinning arrows come up beside the submit button and stay there indefinitely. You never get the confirmation message (‘your form has been submitted’ message when the email was sent, or another message if the e-mail was not sent because a test failed).

    Also, the described solution works with me: going back to Really Simple Captcha version 1.4.

    Thank you ejb!!!

    The only disadvantage is that “forever” WordPress tells me that a plugin is waiting for an update…

    Hi Henk Barreveld,

    After you hit ‘submit’, the spinning arrows come up beside the submit button and stay there indefinitely.

    Did you get a closer look at your senders address? There are a lot providers, who changed in the last days and weeks, that php-sendmail no longer worked with other eMail Addresses then your own.

    Try to change (at mail-section in your form) your “from” field into an valid email address from this domain where your WP are runnig under.

    i hope it will works 😉

    The email address of the sender doesn’t affect the error that I’m getting. Thanks for the suggestion though.

    Was worth a try 😉

    Sorry for my late reaction, I have been away a few days.

    I realize that my description of the problem is incomplete. Here is an update:

    After you hit ‘submit’, the spinning arrows come up beside the submit button and stay there indefinitely. You never get the confirmation message (‘your form has been submitted’ message when the email was sent, or another message if the e-mail was not sent because a test failed). However, if everything was specified correctly the message is sent as you would expect, and it is not sent if anything was wrong.

    So this is not related to an incorrect or not-accepted e-mail address, or so.

    WP 3.4.2
    CF7 3.3.1
    RSC 1.5

    Also getting the same exact problem as described above. after submitting the form it just spins and nothing happens. If I disable any captcha on the form it works fine. Any indication if this will be fixed?

    I debugged this issue, and it’s turn out that the temp-files doesn’t have the correct rights for removal.

    On line 69 till 73 in wp-content/plugins/really-simple-captcha.really-simple-captcha.php the temperary files are set to closed permissions, so they can’t be deleted afterwards. So I changed the permision to:

    /* Mode of temporary image files */
    $this->file_mode = 0777;

    /* Mode of temporary answer text files */
    $this->answer_file_mode = 0770;

    @caljos – Well I hope that doesn’t melt anything but that totally worked. I have no idea what it means, but it worked. Thanks 🙂

    Hi,

    I encountered the same problem and the solution from caljos worked for me too. Thanks!

    @seamoose37 – 0777 matches with read/write/execution permissions on Linux (for all users). Previously the permissions were 0444 (read only for all users). I didn’t read the code but it seems that the captcha files were not regenerated when submitting the form.

    @caljos That totally works. Thanks a lot.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Really Simple CAPTCHA] Submit Appears to Be Timing Out But It's Really Working’ is closed to new replies.