WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Really Simple CAPTCHA] Code image does now show

[Plugin: Really Simple CAPTCHA] Code image does now show

  • I cannot get the code to show. In fact, the hidden form field and image tag are not even included in the HTML code.

    I use:

    <p>Enter the following characters below:<br />
        [captchac captcha-22]</p>
    
    <p>[captchar captcha-22]</p>

    HTML generated:

    <p>Enter the following characters below:
        </p>
    
    <p><span class="wpcf7-form-control-wrap captcha-22"><input type="text" name="captcha-22" value="" size="40" /></span></p>

    Any suggestions?

Viewing 10 replies - 1 through 10 (of 10 total)
  • It is likely due to this issue: Contact Form 1.9.4 and later refers your upload folder setting in Settings > Miscellaneous menu for resolving the base directory for CAPTCHA’s temporary folder. So it may not use wp-contents/uploads/wpcf7_captcha. For example, when your upload folder is set “wp-content/myfiles”, CAPTCHA temp files will be created in wp-content/myfiles/wpcf7_captcha, so you need to make that folder writable.

    The folder location is set under settings > miscellaneous

    Most ftp programs will allow you to set folder permissions 777 will work, though others may suggest a more restrictive setting.

    After making this adjustment mine works, you can see here:
    Plane Charter

    Thanks! I added the upload folder, chmod’ed it and cf7 created its own folder within it. Now, the image is included within the HTML but not created by the script so only the ALT tag is displayed…
    To clarify, no files are actually created within /wp-content/uploads/wpcf7_captcha so while the HTML displays correctly, the image is broken.

    Suggestions?

    GiladG,

    I’m having the exact same problem with one of the websites I run. I’ve got two different WordPress installations – the CAPTCHA image shows up great on one, but not at all on the other. Permissions, file location, everything is identical and is exactly as it should. Were you able to solve this problem? Does anyone else have any other ideas?

    OK, good news, GiladG, I figured it out! This problem popped up after I had moved my blog to a new domain name, and while I was correcting another problem (where uploaded photos to the WordPress install were not showing up), this was fixed as well.

    The problem was with the upload_path variable in the wp_options table in the database. It was still set as the old path, and I updated it to point to the new location with a little SQL:

    UPDATE wp_options SET option_value="/my/new/path" WHERE option_name="upload_path";

    You will, of course, need to edit your path accordingly.

    Hey it works now for some reason I had my upload directory set to only wp-content so I changed it to wp-content/uploads and had to move all my files and then it worked.

    Hi
    I am new to wordpress.the captcha image is not displaying in really simple captcha plugin.Please any one help me.

    Thank you, gentlemen and ladies! I added the wp-content/uploads folder which did not exist, then saved the CF7 again. The image appeared after 10 minutes.

    DeltaHF (or anyone who knows) We seem to need to do what you suggested bc I moved the site after it was designed/set up to the main url and now my captcha isn’t working.

    I tried deleting and re-installing hoping it would work, but it hasn’t.

    I am not that familiar with going into the database to put what you wrote in. Could you give more detailed directions on how to do that. We are on dreamhost if you are familiar with their set up.

    Thank you!

    thanks, it’s works.

    1) create upload folder and give it chmod 777.
    2) re save contact form 7.
    3) enjoy.
    4) sorry for my english 🙂 .

    i had the same problem after changing domains. i did everything of the above and it didn’t work. by chance i happened to go to settings and permalink and change it from custom structure (which I had set originally) back to default and back to custom again — saving each time. everything now works.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Really Simple CAPTCHA] Code image does now show’ is closed to new replies.
Skip to toolbar