Really Simple CAPTCHA
Captcha not working from alternative directory (3 posts)

  1. JohnP
    Posted 3 years ago #

    I've just shifted the contents of a site's wp-content/uploads/ directory to an Amazon S3 bucket.

    I've changed the Media Settings so that the "Store uploads in this folder" field is empty, and I've set the "Full URL path to files" as: http://assets.example.com

    I was not surprised that the captcha stopped working.

    It was working previously, so the server is good to go.

    I made a new directory one level up at: /wp-content/wpcf7_captcha

    Permissions are 777; I can see an index file in my browser, so the directory exists.

    I added the following line to wp-config.php:
    define( 'WPCF7_CAPTCHA_TMP_DIR', '/wp-content/wpcf7_captcha' );

    But if there is a captcha in the form, I get the error:

    This contact form contains CAPTCHA fields, but the temporary folder for the files (/wp-content/wpcf7_captcha) does not exist or is not writable. You can create the folder or change its permission manually.

    I've tried reinstalling both Really Simple Captcha and Contact Form 7, but it still will not work.

    I've even tried flushing the permalinks.

    I'm out of ideas. Any assistance will be greatly appreciated.


  2. Takayuki Miyoshi
    Plugin Author

    Posted 3 years ago #

    define( 'WPCF7_CAPTCHA_TMP_DIR', '/wp-content/wpcf7_captcha' );

    This should be full path from root. Do you really have wp-content on the root directory?

  3. JohnP
    Posted 3 years ago #

    Yes, it is a standard install, with WP in the root directory.

    I can see an index file in the temp directory at this URL:

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Really Simple CAPTCHA
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic