Support » Plugins » [Plugin: Really Simple CAPTCHA] CAPTCHA not accepting the proper characters

  • I installed the latest Contact Form 7 as well as the latest Really Simple CAPTCHA (both from the plugin installed in WP 2.9) and everything works until I try to submit a test form. Even though I can verify the CAPTCHA I am entering is what is being displayed, the system tells me it is wrong.

    I have tried upper-case as well as lower-case characters and nothing is working. Are cap characters required or would lower-case work?

    Not seeing anything of the recent forums stating these same issues, suggestions?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Are you using some kind of cache plugin?

    Having the same problem here. I’m definitely entering the right code, but it’s giving a “Validation errors occurred. Please confirm the fields and submit it again.”

    Upper-case, Lower-case doesn’t work. I have no cache plugin (thanks takayukister). It was working, I believe this was even after the upgrade to WP version 2.9.1.

    Does this still occur even if you would deactivate all other plugins and switch to the default theme?

    Thanks takayukister, I’ve only just had the time to play around with it.
    It seems to be working ok now, I believe it was the CAPCHA id? number – “captcha-123” – as I have 3 separate contact forms on the site, I just did a copy/paste for the CAPCHA part of the form. Giving each form a unique number seems to have fixed the problem.

    Definitely. It must be unique name for each pair of captchac/captchar.

    Thank for the great plug-in. I’ve used it successfully on one site, but now I’m having a problem similar to ProjectZero’s described above and I can’t figure it out.

    It tells me the code is entered incorrectly, but only on the FIRST try. When I enter it the second time, it works fine.

    I’ve tried reinstalling the CAPTCHA plug-in, and following the advice you gave above — deactivating all other plug ins and switching to the default theme. I experienced the same problem.

    Any ideas?

    Edit: the problem occurs in Firefox 3.5.8, but not IE 6.

    rskaskiw, do you use Contact Form 7? If so, which version do you use?

    I guess you are also using some kind of cache plugin. It is a typical trouble when cache and the CAPTCHA plugin are conflicting.

    And, showing your site’s URL would be helpful.

    Thanks for the quick reply.

    I’m using Contact Form 7 version 2.1.2.


    The problem still occurred when I deactivated all other wordpress plug-ins, but for the record, here’s a list of them:
    Capability Manager
    Contact Form 7
    Global Post Password
    Google Maps for WordPress
    PixoPoint Menu Plugin
    Really Simple Captcha

    Meh, I had this problem too. But its fixed now.
    Here are the exact things I did with these plugins that created and fixed the problem, in order.

    1.) installed the Simple Contact Form 7
    2.) went to edit my form
    3.) went to generate the captcha but it said I needed simple captcha
    4.) installed the simple captch
    5.) went back to edit my form
    6.) generated the captcha code
    7.) copied the captcha code into my form
    8.) saved the form
    9.) copied the code into a text widget
    10.) refreshed my page and didn’t see the image
    11.) went back to the generate captcha code
    12.) changed the background and foreground color
    13.) copy the new generated captcha code
    14.) paste new code into form and save the form
    15.) think I forgot to save one for the input field tho <!– I think this caused the problem right here cause… ->
    16.) refreshed the page and could see the image now, but the submit did not validate.
    17.) decided to start over
    18.) deleted the form and made a new one
    19.) did everything right this time by changing the color
    20.) copied both codes over correctly
    21.) saved the form
    22.) refresh the page and tested submit, works perfect now.

    Thanks for the really simple plugin that does exactly what I need. I might work on extending because I would like the subject to be a drop down box that has only the choice for my categories sections. There is not a live site yet, all testing done with latest version of xampp and wp with only swfflash plugin installed next to it.

    rskaskiw, I checked your site. It’s definitely a behavior you see when conflict is occurring with some kind of cache mechanism.

    Insert this line into your wp-config.php for testing:

    define('WP_CACHE', true);

    @newbitech – Thanks, but I don’t think I’m missing a field, because I’m getting the same error on both forms.

    @takayukister – It seems to be working with that line inserted into my wp-config.php Thanks!

    Before inserting I realized I had to do the following to reproduce the error:
    1. Fill out a form. (the message is sent)
    2. Refresh the page.
    3. Fill out the form again. (error message, even when filled out correctly)

    I added the suggested line to my wp-config, cleared my cache & reloaded the page containing the form. Now I’m unable to reproduce the error.


    had the same problem as rskaskiw

    solved with define(‘WP_CACHE’, true);

    takayukister, thanks for great plugin and help!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Really Simple CAPTCHA] CAPTCHA not accepting the proper characters’ is closed to new replies.