[Plugin: Really Simple CAPTCHA] Captcha images disappearing with WP 2.8.1 (18 posts)

  1. thierrydehove
    Posted 7 years ago #

    these captach were working perfectly before I updated my WP.
    do you have any idea why they are disappeared ?

    Many Thanks in advance for your help

  2. Takayuki Miyoshi
    Posted 7 years ago #

    No, I have no idea for now. Captchas are working on my site with the latest WordPress.

  3. thierrydehove
    Posted 7 years ago #

    Lucky you ;-)
    I have removed it and re-installed.. nothing and also some of my fields are not working ;-)

  4. thierrydehove
    Posted 7 years ago #

    Ok I fixed the bug of my fields now ;-)

  5. thierrydehove
    Posted 7 years ago #

    Hello again
    I have checked with my hosting company, I have asked them this:

    Hello For my blog made with Word Press, I have added a form with some Captcha http://www.thierrydehove.com/25-years-in-this-business/custom-web-banner-des ign-form/
    As you can see these images dont appeared. And they say: To use CAPTCHA, you need GD and FreeType library installed on your server. Also, the contact-form-7/captcha/tmp folder must be writable. Contact Form 7 1.8 and later require wp-contents/uploads/wpcf7_captcha folder writable, instead of contact-form-7/captcha/tmp.

    I have chmod usr/home/tanamalt/public_html/thierrydehove.com/wp-content/plugins/really-si mple-captcha by 777

    and they replied to me:
    From your description, it sounds like the setup should be correct. When loading the http://www.thierrydehove.com/25-years-in-this-business/custom-web-banner-design-form page, no errors are generated in the Apache logs. You will most likely need to contact the maker of this particular software for advice on how to resolve the problem.

    What do you think ?
    for information, I didn't find this file "tmp".. maybe it's the answer ?

    Please let me know,
    Thanks in advance, Thierry

  6. SnakeCave
    Posted 7 years ago #

    Hi !

    I'm having the same problem i think...

    When i use the plugin with the Contact Form 7, it tryes to load the captcha image from: "/wp-content/uploads/wpcf7_captcha/"

    But the temp / image files are stored in this folder:

    "/wp-content/wpcf7_captcha/" - How can i change that ???

    Kind regards,

  7. mnr
    Posted 6 years ago #

    Just to confirm this plugin works with version 2.8.4

  8. clinton4
    Posted 6 years ago #

    I can't get this plugin to work and i have the latest version of the plugin and WP. What could be wrong?

  9. Quan_master
    Posted 6 years ago #

    So does this work with WP 2.8.4???

  10. silvalex
    Posted 6 years ago #

    Not working for me on 2.8.4 The captcha does not show images.

  11. clinton4
    Posted 6 years ago #

    Did any of you that has problems with showing images with WP 2.8.4 figure out what the problem was?

  12. johanndyck
    Posted 6 years ago #

    I manage several websites all with the latest version of WP. I'm working on another one, and the image isn't showing up for the CAPTCHA in the comment form I made with Contact Form 7. It's working on a ton of sites, just not this new one. Not sure what I'm doing wrong.

  13. scarcius121
    Posted 6 years ago #

    Just posting to confirm that this plugin does work with 2.8.4, at first images did not show up but all I had to do was chmod the wpc7_captcha folder to give it the correct write permissions.

  14. MagicG
    Posted 6 years ago #

    If you have problems :
    1) Check your upload path (settings->micellaneous)
    2) For Contact form 7, check that the "wpcf7_captcha" folder exist in your upload path
    3) Check on the server that the folder have the write permissions.

  15. LarryGauthier
    Posted 6 years ago #

    I had exactly the same problem - WP v2.8.5, Really Simple Captcha v1.0, used with Contact Form 8. In FF the image box was a blank white rectangle. In IE the box had the word "captcha" in it.

    Thanks to MagicG, I traced my problem to the Upload Path - which in WP v2.8.4 was correct (and thus Captcha worked on that version) but when I migrated my app to a new directory for v2.8.5, the Upload Path still pointed at the old 2.8.4 upload location. Correcting Upload Path cured the problem.

    I have also updated to Captcha v1.1 and it's working fine.

  16. workingroup
    Posted 6 years ago #

    I use RS Captcha 1.1 and Contact 7 plugins in my theme with wordpress 2.8.6

    I created several forms with captcha requirements in Contact 7 and put them into pages.

    The captcha images do not appear at all.

    I gather from the posts above the problem may be the directory problem.

    So I deinstalled the RS Captcha plugin, modified the directory setting under Settings>Miscellaneous of the WP interface, reinstalled the RS Captcha plugin, and even deactivated and reactivated the Contact 7 plugin: still no captcha images appear, so I gather that I must tell my web man to make the wpcf7_captcha folder writable....

    It would be good to let WP 2.8.6 users know about all these issues from the start...if it works, I'll let you know...

  17. megami20
    Posted 6 years ago #

    With my form, sometimes all 4 captcha characters show up just fine. Sometimes only 2 or 3 show up with the following error:

    Warning: imagettftext() [function.imagettftext]: Could not read font in /nfs/c05/h01/mnt/69578/domains/eunicehart.com/html/wp-content/plugins/really-simple-captcha/really-simple-captcha.php on line 104

    If I refresh, sometimes it works fine, sometimes it doesn't. I am using WP 2.8.6 and I just downloaded Contact 7 and Really Simple Captcha today. Obviously have what is needed to show the captcha, it just doesn't show up all of the time.

    Has anyone been able to figure this out?

  18. kref
    Posted 6 years ago #

    After update the captha disappearing in my order form

    i have
    * PHP Version: 5.2.6-1+lenny4
    * System: Linux
    * GD Support: Yes!
    * GD Version: 2.0 or higher
    * TTF Support (FreeType): Yes!
    * JPEG Support: Yes!
    * PNG Support: Yes!
    * GIF Read Support: Yes!
    * GIF Create Support: Yes!

Topic Closed

This topic has been closed to new replies.

About this Topic