Support » Plugins and Hacks » [Resolved] [Plugin: Really Simple CAPTCHA] Blank Images

[Resolved] [Plugin: Really Simple CAPTCHA] Blank Images

  • Hi,

    I wonder if anyone can help as I have a very strange problem which is doing my head in.

    I have installed Contact Form 7 and Really Simple Captcha. I have confirmed the upload folder is correct and writable. I have confirmed that the captcha code is correct, referencing the same challenge and response and even tried playing around with the settings to change the presentation and font colour – but – each and every time the image is blank.

    Every time I visit the contact page a new file is being created and this file is consistent with the image in the page. You can even right click and save the PNG image but the image is blank.

    I have confirmed that I have freetype and GD installed and updated them to make sure they are the correct version and also installed the latest versions of contact form 7 and really simple captcha.

    I have also spent the last two hours searching forums for anyone having the same problem, but I just can’t crack it, I’m stuck.

    Has anyone had a similar problem and were they able to resolve it?

    Your help is appreciated.



Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Takayuki Miyoshi


    Where is the contact page?

    Hi Takayuki,

    Good question – that would help wouldn’t it.

    It’s here:


    Thank you.


    Plugin Author Takayuki Miyoshi


    Ok. Confirmed an image is generated but it is all white. Then, how did you create that? What captchac tag did you actually put?

    Hi Takayuki,

    I was following the guide here:

    Really Simple CAPTCHA

    I tried:

    Input this code: [captchac captcha-118 size:l fg:#00ff00 bg:#ffffff]
    [captchar captcha-118 4/4]

    But its currently set to this:

    Input this code: [captchac captcha-170]
    [captchar captcha-170 4/4]

    I hope you can help.

    Thank you.


    Plugin Author Takayuki Miyoshi


    Ok, the codes seem correct.

    I’ve seen a similar issue before. In that case, the cause of the problem was PHP’s bug, and resolved by updating PHP to the latest version.


    I am having the exact same problem. I have been assured by my hosting company (GoDaddy) that we are using the latest version of PHP.


    Any other thoughts on how to resolve this?



    Please disregard my question above. This appears to be a common issue with this plugin.

    After wasting several hours trying to resolve the issue w/ Really Simple CATCHA cited in the earlier posts, I decided to find an alternative plugin. I went with Fast Secure Form – it was easy to install, worked correctly, and was easy to tailor.

    While I like Contact Form 7, the integration of a CAPTCHA tool needs some significant work.

    In my case it was fixed by changing the font used for rendering.

    First I copied the fonts from “/usr/share/fonts/truetype/ttf-dejavu” to the plugin’s directory (…/htdocs/wp-content/plugins/really-simple-captcha/ttf-dejavu).

    Then tweak the really-simple-captcha.php to change the fonts array…


    $this->fonts = array(
    dirname( __FILE__ ) . ‘/gentium/GenAI102.TTF’,
    dirname( __FILE__ ) . ‘/gentium/GenAR102.TTF’,
    dirname( __FILE__ ) . ‘/gentium/GenI102.TTF’,
    dirname( __FILE__ ) . ‘/gentium/GenR102.TTF’ );


    $this->fonts = array(
    dirname( __FILE__ ) . ‘/ttf-dejavu/DejaVuSerif-BoldItalic.ttf’,
    dirname( __FILE__ ) . ‘/ttf-dejavu/DejaVuSerif-Bold.ttf’,
    dirname( __FILE__ ) . ‘/ttf-dejavu/DejaVuSerif-Italic.ttf’,
    dirname( __FILE__ ) . ‘/ttf-dejavu/DejaVuSerif.ttf’ );

    NOTE: I am using Debian but the same fonts should be available in Ubuntu (or try using a different one – just NOT gentium).

    It worked for me… hope it helps someone.

    My captcha image doesn’t show up often now too after the latest WordPress UG. If I go into properties of the missing image it show a file number that has not been generated on the server. I can see what the file numbers are and there is no match for the one it is trying to use. What am i missing? We did switch providers a few months ago. I do not see the path you suggest checking in wordpress anymore.

    I have an update…

    As I still couldn’t get mine to work and PHP is a supported version I decided to carry out dr.strangelove’s suggestion.

    It is only when I went into the existing gentium font folder I found that the TTF font files were not there! For some reason, the auto-installation through WordPress did not place these files.

    I downloaded really simple captcha, extracted the files, found the TTFs and uploaded these to the gentium folder and voila! It works…

    So, if anyone else gets a blank image, please check that the TTF files are in the gentium folder, if not, that’s the reason.

    Phew.. got there at last 🙂


    I was having a similar issue on one of the sites I’m administrating and the fix I found was to delete the .htaccess file from /wp-content/uploads/wpcf7_captcha. Everything’s now displaying as expected.


    Thank you so much rwassell for your solution! I’ve been beating my head trying to figure out why I was getting the background of my CAPTCHA images but not the foreground with the letters and numbers. Turns out all I had to do was copy the gentium folder to the plugin’s folder and voila! After attempting to edit htaccess files, the plugin’s PHP file, check my PHP version, edit permissions, etc. this was super easy.

    So thanks again for sharing that solution!

    I was having a similar issue because there weren’t all the fonts uploaded from the localhost captcha plugin folder to the remote server.


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: Really Simple CAPTCHA] Blank Images’ is closed to new replies.