Support » Plugin: Ready! Ecommerce Shopping Cart » [Plugin: Ready! Ecommerce Shopping Cart] class "dispatcher" missing

  • Resolved kingeofdremes

    (@kingeofdremes)


    I’ve only just started working with WordPress, and run everything on my local host (XAMPP). I installed the newest edition of the Ready Ecommerce (0.2.7) and it returns the error:

    Fatal error: Class ‘dispatcher’ not found in [My WordPress directory]\wp-content\plugins\ready-ecommerce\ecommerce.php on line 42

    The plugin was not activated.

    http://wordpress.org/extend/plugins/ready-ecommerce/

Viewing 15 replies - 1 through 15 (of 35 total)
  • Plugin Author Ready! Developer

    (@ukrainecmk)

    Hello.
    Please check if there is such file in plugin directory classes/dispatcher.php . If no – please add it from plugin package.

    Regards,
    Alexey.

    avennela

    (@avennela)

    I am having the same problem. File exists in plugin directory classes/dispatcher.php. Let me know how to resolve this.

    kingeofdremes

    (@kingeofdremes)

    Yes, the file is in the plugin directory.

    Plugin Author Ready! Developer

    (@ukrainecmk)

    Please check:
    1. Permissions to folder classes and file dispatcher.php
    2. Content of file dispatcher.php – is there lines:
    class dispatcher {

    Regards,
    Alexey.

    kingeofdremes

    (@kingeofdremes)

    To date, I’ve been running everything through XAMPP htdocs on my Windows 7 computer.

    While trying to resolve this issue, I have added the BulletProof Security plugin, which lists permissions for a few of the files and folders used in WordPress. As part of the installation, htaccess was added to my root WordPress directory, among other files throughout the system. BulletProof claims that my system is working correctly, and lists a number of files and folders along with their permission settings in the standard 3-digit format. None are currently set according to BPS recommendations. The classes folder and dispatcher.php are NOT included in the BPS table.

    Most of the info I’ve seen suggests that file permissions is best handled through FileZilla, an FTP server program. I’ve since installed FileZilla, and have created an ftp site on my local computer. I receive a 504 error when trying to set permissions on files I copy to the ftp folder; apparently, my version of Windows does not change permissions in this way even with FileZilla. I am doing everything from my home computer; I have administrator priviledges for all files and folders, and so far as I can tell, after reading about others’ experiences with FileZilla on Windows computers, permissions are actually supposed to be set by right clicking on a file or folder -> Properties, and unchecking the Attributes:Read-Only checkbox without any need for FileZilla. This action DOES NOT work. Advice on changing permissions is needed.

    The dispatcher.php file DOES include code that seems OK.

    Still stuck on this… thank you for your help so far, Alexey!

    Plugin Author Ready! Developer

    (@ukrainecmk)

    Good, but can you tell me exact permissions – 3 digits – to classes dir and dispatcher.php file?

    kingeofdremes

    (@kingeofdremes)

    I wish I could, but no. The BPS table gives the following information:

    DSO File and Folder Permissions / Recommendations
    File Name
    Folder Name	File Path
    Folder Path	Recommended
    Permissions	Current
    Permissions
    .htaccess	../.htaccess	644	666.
    wp-config.php	../wp-config.php	644	666.
    index.php	../index.php	644	666.
    wp-blog-header.php	../wp-blog-header.php	644	666.
    root folder	../	755	777.
    wp-admin/	../wp-admin	755	777.
    wp-includes/	../wp-includes	755	777.
    wp-content/	../wp-content	755	777.
    wp-content/bps-backup/	../wp-content/bps-backup	755	777.

    Going through Windows’ folder properties gives only the Attributes:Read-Only checkbox I mentioned. Nothing else I’ve done or seen today gives a 3 digit code for permissions for files or folders.

    Only after uploading my root htaccess file [randomly selected to test this out] to the ftp site did I finally see the right-click option of “file permissions…”. A dialog box opens with nine checkboxes total for Owner/Group/Public permissions. All are set to solid blue boxes, and the code provided is “xxx”. I get the same information when I load the classes folder. When I try to set the permissions to anything else, I get the 504 error mentioned in my last message. So how do I get and set these permissions?

    Plugin Author Ready! Developer

    (@ukrainecmk)

    In your table 644, 666, 755, 777 is this digits. If you can setup permissions using filezilla (for example) – set permissions for all directory with our plugin to 755 (now you have there “xxx”, use checkboxes to set it to 755).

    Regards,
    Alexey.

    kingeofdremes

    (@kingeofdremes)

    The table provided by BPS does not have a method for changing file permissions. It only provides details, and does not include the classes folder or Dispatcher.php.

    Back to FileZilla. I right click on a file uploaded to the ftp folder, and select “File Permissions…”. The “xxx” code is displayed in the dialog box mentioned earlier. When I try to change the “xxx” to “755”, FileZilla reports as follows:

    Status:	Set permissions of '/PrivateLink/test/.htaccess' to '755'
    Command:	CWD /PrivateLink/test
    Response:	250 CWD successful. "/PrivateLink/test" is current directory.
    Command:	SITE CHMOD 755 .htaccess
    Response:	504 Command not implemented for that parameter

    and

    Status:	Set permissions of '/PrivateLink/test/classes' to '755'
    Command:	CWD /PrivateLink/test
    Response:	250 CWD successful. "/PrivateLink/test" is current directory.
    Command:	SITE CHMOD 755 classes
    Response:	504 Command not implemented for that parameter

    When I then check .htaccess and the classes folder permissions, both have stayed “xxx”. This is what I mean by a 504 error.

    Plugin Author Ready! Developer

    (@ukrainecmk)

    /PrivateLink/test/ – is this directory where our plugin is stored?

    Regards,
    Alexey.

    kingeofdremes

    (@kingeofdremes)

    Does your plugin need to be installed on an ftp-accessible folder?

    My only concern at this time is in getting and setting permissions. So far, the closest I’ve come to accessing these permissions is through FileZilla, and only if they are located in an ftp-accessible folder. And, as noted, setting them here does not currently work.

    For testing purposes in getting and setting permissions, I have copied only the classes folder from your plugin, and the .htaccess file to my ftp folder. Nothing else currently resides anywhere on my ftp folder. My WordPress site is currently only local, and runs via XAMPP htdocs. Everything is saved there.

    Regards… and I’m off until tomorrow 🙂

    Plugin Author Ready! Developer

    (@ukrainecmk)

    Folder must be at least redable and all files (.php) must be executable, plugin must be in plugins wordpress directory.

    Regards,
    Alexey.

    kingeofdremes

    (@kingeofdremes)

    All I did was download and install the plugin the same way I do any other. I never set any permissions, or moved the plugin from the WordPress plugin directory. I have no reason to think that the files are unreadable or can’t be executed, as I’ve done nothing to them.

    I’ve only been looking into permissions because that was the first thing you mentioned in resolving this issue. Do you have any other suggestions?

    Regards

    Plugin Author Ready! Developer

    (@ukrainecmk)

    Yes. Go to file functions.php in plugin directory, and after line 60 (before 61) insert next code:
    var_dump($path);
    Put here all output from your site for now.

    Regards,
    Alexey.

    kingeofdremes

    (@kingeofdremes)

    Alrightey.
    Right after I did that, I tried to enable the plugin again. Now it reports:

    string(19) "S_CLASSES_DIRdb.php" string(26) "S_CLASSES_DIRinstaller.php" string(23) "S_CLASSES_DIRmodule.php" string(22) "S_CLASSES_DIRmodel.php" string(21) "S_CLASSES_DIRview.php" string(27) "S_CLASSES_DIRcontroller.php" string(23) "S_CLASSES_DIRhelper.php" string(20) "S_CLASSES_DIRtab.php" string(27) "S_CLASSES_DIRdispatcher.php" string(22) "S_CLASSES_DIRfield.php" string(22) "S_CLASSES_DIRtable.php" string(22) "S_CLASSES_DIRframe.php" string(24) "S_CLASSES_DIRmvcHelp.php" string(21) "S_CLASSES_DIRlang.php" string(20) "S_CLASSES_DIRreq.php" string(20) "S_CLASSES_DIRuri.php" string(21) "S_CLASSES_DIRhtml.php" string(25) "S_CLASSES_DIRresponse.php" string(29) "S_CLASSES_DIRfieldAdapter.php" string(31) "S_CLASSES_DIRshippingModule.php" string(30) "S_CLASSES_DIRpaymentModule.php" string(26) "S_CLASSES_DIRvalidator.php" string(23) "S_CLASSES_DIRerrors.php" string(22) "S_CLASSES_DIRutils.php" string(29) "S_CLASSES_DIRmodInstaller.php" string(30) "S_CLASSES_DIRfilegenerator.php" string(26) "S_CLASSES_DIRwpUpdater.php"
    Fatal error: Class 'dispatcher' not found in C:\xampp\htdocs\AnWordpress\wp-content\plugins\ready-ecommerce\ecommerce.php on line 42

    Let me know if there is anything further I can do with this. Again, thank you for your help thus far.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘[Plugin: Ready! Ecommerce Shopping Cart] class "dispatcher" missing’ is closed to new replies.