WordPress.org

Forums

Ready! Ecommerce Shopping Cart
[resolved] add to cart and buy now (23 posts)

  1. jgmarsh
    Member
    Posted 2 years ago #

    Really nice plugin!
    When I set up a product the selling page has both a 'add to cart' button and a 'buy now' button. Both seem to do the same thing. Why do I need both?
    Thanks
    John

    http://wordpress.org/extend/plugins/ready-ecommerce/

  2. readyshoppingcart
    Blocked
    Plugin Author

    Posted 2 years ago #

    Hi!

    Thank you for that information, we'll fix that in the next release

  3. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Hello.
    When you press "Add to cart" there must be pop-up message after product has been added to cart, and no redirect to checkout. If you have some redirects - please, tell us version of plugin that you use. Also link to your site will be very helpful.

    Regards,
    Alexey.

  4. jgmarsh
    Member
    Posted 2 years ago #

    When I press "add to cart" a line appears in green "Product was added to cart"
    When I press "buy now" the same happens.

    I am using version 0.2.9.1

    http://www.zhong-ding-centre.com/resources/ebooks/

    Thanks for any help

  5. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Is this product added using shortcode?

    Regards,
    Alexey.

  6. jgmarsh
    Member
    Posted 2 years ago #

    The only thing on the page is

    [product id="516"]

    Thanks
    John

  7. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Ok, good. We will try to reproduce and fix it in the coming days.

    Regards,
    Alexey.

  8. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    We didn't reproduce this bug. But I found one thing on your site. There are no footer on your template. Is this correct? You see, we load some scripts in footer, and as you do not have it on your template - they didn't load. I think that the problem is here. We will try to resolve this in our next release (try to load footer scripts in the begining of the page).

    Regards,
    Alexey.

  9. jgmarsh
    Member
    Posted 2 years ago #

    Hi
    There are footers in my template but I took them out. I will put them back in and see what happens.
    Thanks
    John

  10. jgmarsh
    Member
    Posted 2 years ago #

    Hi
    Putting the footer back in sorted the problem.
    Thanks for your help

    There is still the problem of my products not showing after the latest update release. Is there any news on this.
    Hope you can solve this as Ready! is the best eCommerce plugin I have tried.

  11. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Hello.
    Please provide us with link to page, where products not showing.

    Regards,
    Alexey.

  12. jgmarsh
    Member
    Posted 2 years ago #

    It's the Products page in the Ready! Ecommerce part of the admin area.

    Thanks
    John

  13. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Sorry, but I can see only one product on your site at all using next request:
    http://www.zhong-ding-centre.com/?post_type=product

    Regards,
    Alexey.

  14. jgmarsh
    Member
    Posted 2 years ago #

    I have entered 2 products in the admin area and before the recent update both of them were visible. Now it says at the top of the screen there are 2 products but only shows the latest one below.
    I have looked in the database using phpmyadmin and both products are there.

    Thanks
    John

  15. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Ok, please provide me with alias for second product (for first it is ilmu-2 ?).

    Regards,
    Alexey.

  16. jgmarsh
    Member
    Posted 2 years ago #

    men-of-power

  17. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

  18. jgmarsh
    Member
    Posted 2 years ago #

    That link just sends me to the welcome page of the website.

  19. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    I think this means that there are no such product or post, or this product is not published. You can provide us your admin credentials to wordpress site using contact form in main page of our plugin in your admin are and we will look through your admin are. Please also print in message link to this post.

    Regards,
    Alexey.

  20. jgmarsh
    Member
    Posted 2 years ago #

    Ok, sent

    If you go to the Product page and search for
    men of power
    it appears, which shows that it is there somewhere

  21. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Something strange goes here.
    http://www.zhong-ding-centre.com/wp-admin/edit.php?post_type=product
    If you will look into sourse code, you will see that it ends right after cell with description for Ilmu product must start.
    Than I go to http://www.zhong-ding-centre.com/product/men-of-power/ - and see your product.
    After that when I go to http://www.zhong-ding-centre.com/?post_type=product - I see only part of your first product.
    And also - there are some javascript error on page, something about mp3 ("Syntax error, unrecognized expression: [href$=.mp3]").
    But most of all - it is very strange that after description of product "Ilmu" there are nothing at all in admin area. Please check other plugins on your site - they can exit scripts parsing on this step.

    Regards,
    Alexey.

  22. jgmarsh
    Member
    Posted 2 years ago #

    Would you advise that I re-install everything to have a clean start. There are obviously quite a few problems.

  23. Ready! Developer
    Blocked
    Plugin Author

    Posted 2 years ago #

    Yes, it is quite a few problems. But unfortunately I can't tell you what else can be reason for this. In this case I can recomend you to deactivate plugins one-by-one, after deactivating one plugin - update page with products list in admin area, if problem still exist - activate it and go futher.
    But sure - we will try to reproduce this bug, and if we will be able to reproduce it - sure, it will be fixed, but now I can tell you that no one from our team didn't encounter this problem.

    Regards,
    Alexey.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic