Support » Plugins » [Plugin: Quick Post Widget] Can't get File Manager to appear

  • Resolved Dekortage


    I am setting up a small moderated WordPress site on a private network. We would like users to be able to make posts and upload files without logging into the back end. The Quick Post Widget works fine for this EXCEPT for the file uploading part. I think we’re supposed to be able to do this:

    1. Click on the “Editor” button in the widget area to get a popup dialog box with TinyMCE.

    2. Click on the “Insert/Edit Media” icon to get the TinyMCE insertion dialog.

    3. Click on the “Browse” file browser icon to open the File Manager dialog.

    This is all fine, except that the File Manager dialog box is completely empty. Just a big white box inside the dialog frame. It has the close “X” button in the top right corner, which works, but there is no file uploading form, or in fact anything at all.

    What am I missing? Is there a security setting somewhere? A pathname to hack? Any advice will be much appreciated. Thank you.

    (FYI: server is running PHP 4.3, I believe, if that matters)

Viewing 15 replies - 1 through 15 (of 17 total)
  • Resolved this problem by editing the ‘docroot’ in the ‘config_tinybrowser.php’ file to this:

    $tinybrowser[‘docroot’] = ”;

    The file manager window now appears as it should. However, it is headlined with an error that it is “Unable to create the ‘/mysite/localgroup/wp-content/uploads/shared/media/’ directory”. As a result, I cannot actually upload a file That directory exists on the server and has full read/write priveleges for everyone (UNIX permissions 777) so I can’t figure out why it does not see the directory. Maybe there’s another pathname I need to edit someplace.

    Thanks for the docroot tip. After fixing that, I can see the file manager page again, but I am also experiencing the same permissions error. Although when I first tried this plug-in before modifying the docroot, the upload file completed successfully but then the file manager page went blank. So not sure how the docroot is playing into this issue.

    Interestingly enough if I delete the uploaded file from the directory, after file manager goes blank, the file manager feature shows up again. I am wondering if it has anything to do with file size. More testing to come…

    I edited the config to place a file limit of 1.5MB for images, which is what I use the most and that seemed to solve my problem without having to change the default setting for docroot.

    Thanks for the information. I’m still struggling with just getting the file manager window to appear without the permissons error.

    I figured out the problem. The file upload plug-in requires the multibyte string functions in PHP. These are built into PHP5, but if your host is running PHP4, the functions have to be included in your host PHP configuration. In my case, they weren’t included and there was no way that end-users could add them. However, PHP5 is an option on my host, so I switched to that and everything began to work fine.

    Note that after switching to PHP5, I had to restore the docroot back to the original default (instead of blanking it out). Under PHP4, the multibyte functions would cause the PHP script to fail, so the File Manager window code would never appear — it just came up blank (my original problem, above). But if I blanked out the docroot, the plug-in code would run into the permissions error, which caused the plug-in to skip the code with the multibyte functions, so the File Manager code would appear but wouldn’t be able to see or upload any files. Fun, eh?

    But PHP5 solved it all.

    Great information, but I am on PHP 5 (see below for settings) and I am still running into the issue. For now, I have set the upload size limit to 1.5MB to avoid the issue, but I would like to remove that limitation as it is annoying.

    Multibyte Support enabled
    Multibyte string engine libmbfl
    Multibyte (japanese) regex support enabled
    Multibyte regex (oniguruma) version 4.4.4
    Multibyte regex (oniguruma) backtrack check On

    You said you changed the config for the file upload size. Was that the config in the plugin? Or the config in WordPress? Or did you do something in a php.ini file?

    What is your max upload size in PHP?

    In the file ‘config_tinybrowser.php’ there is an option to set the file size for images, media and other files. It is by byte, so I did the math and applied a max of 1.5MB or 1572864 bytes as the max.

    And it was set to zero previously? (e.g. no limit)

    Is there any chance your problem is on the browser end? Depending on the config, sometimes IE has problems with uploads that Firefox does not (or, occasionally, the other way ’round).

    Yes, it was originally zero (no limit by default). I am using Chrome and have not tried another browser, but regardless other users will be leveraging the upload feature and I will not be able to control the browser they choose to use.

    I agree the issue is very odd. I even have the resize feature set, thinking it would automatically reduce the file size and all should work. Well the file uploads and is resized, but the file manger screen continues to go blank. Therefore, I put the file size limit back on until there is another solution to try.

    Anyone else have an idea on why the file manager goes blank after uploading a large image file (2+ MB)? I am finding the need to resize images before uploading to be a big pain for everyone that posts.

    That does sound like a pain. I’m not having the problem — I’ve tested it with 2.5mb and 3.0mb files.

    I don’t know how much you know about PHP, but I would consider editing the upload files and putting in some breaks or echos throughout it, trying to trace the point it is breaking. That’s what I did and finally tracked the break to the multibyte functions.

    I’m not sure, but in thinking about it further, I would see if it has anything to do with the system’s post-upload thumbnail generation timing out over the file size.

    Does it make a difference if you upload the file via the “Link” file insertion, versus the “Media” insertion? Not sure if upload via Link would include the thumbnail stuff.

    Or, maybe I’m talking out of my butt. But I’m sorry that you have the problem. I hate when software doesn’t work correctly and you can’t figure out what is going on.

    I found and solved my issue. I was running out of memory space, so I added the following line to the config_tinybrowser.php, just after the time limit settings.

    ini_set('memory_limit', '128M');

    Now all works fine.

    Fantastic. That’s what I was getting at with the timing-out over file size, though I wasn’t exactly right.

    Glad it’s working for you.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Quick Post Widget] Can't get File Manager to appear’ is closed to new replies.