Support » Plugin: Quick Chat » [Plugin: Quick Chat] Chat is not working with s2Member?

  • I have installed s2Member plugin which modifies the access levels of the users.

    The only way I can see chat operation is when the logged in user(haven’t tried with guests[not logged in]) is an Administrator.

    I am using the User Role Editor.

    Can you please tell me which capabilities I need to have enabled at minimum in order for the chat to work?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I am using W3 Total Cache and I read about some incompatibilities.
    So I disabled all caching methods but still no luck.

    Then I checked at your code, quick-chat.php under function quick_chat_init() but couldn’t find where the problem might be…

    I even included just before the closing bracket of the quick_chat_init() function, this code:

    if(is_user_logged_in() && !current_user_can('manage_options') && $quick_chat_ip_blocked == 0) {
        	$quick_chat_no_participation = 0;
        	$quick_chat_must_login = 0;
        	$quick_chat_user_status = 1;

    but I still get the same result…
    Chat area shows up, username is displayed, just sound and scroll are visible(which denotes a non admin user) but previous messages are not displayed and the user can’t post!!!

    I did have a quick look on the .js files but I couldn’t find something!!!

    I have made an exhaustive test trying to eliminate various different plugins that might be causing problems on the Quick Chat plugin.
    So I made a fresh new install of WordPress installing all the modules I had on the aforementioned site,

    This test site is at : has Quick Chat, Quick Count, Quick Flag, W3 Total Cache, BuddyPress and some related to BuddyPress plugins.
    The only difference is the S2Member plugin that is not installed.
    On this site all three(3) Quick plugins work flawlessly!!!
    Quick Chat is the beta version 3.50!!!

    So the end result is that Quick Chat and S2Member have compatibility issues!!!
    Please advice.

    Thank you!

    Plugin Author Marko-M


    Hello yes, Quick Chat isn’t compatible with S2Member plugin. This has been reported already. I don’t use S2Member plugin and to be honest S2Member is very large piece of code to debug. I just haven’t found inspiration to dive into this.



    What kind of issues? I have s2member and one user level #1, no issues so far?

    Plugin Author Marko-M


    Hi wpaholic. I can’t remember what was the issue, it was a year ago and it is possible that some new version of S2Member or Quick Chat solved some of the issues.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Quick Chat] Chat is not working with s2Member?’ is closed to new replies.