Query Multiple Taxonomies
Found for widget, but Not Found for display (4 posts)

  1. Joy
    Posted 5 years ago #

    I've got a confusing mess on my local test site. I used several different plugins to create custom post types and then custom taxonomies. Then I found Query Multiple Taxonomies, which is ideal for what I'm doing. I tried it and it worked. So I continued to develop the site and get the data uploaded into my custom post type.

    Now that I have data loaded, I am using "Ultimate Post Type Manager" and "Ultimate Taxonomy Manager" and "Custom Post Archives". The QMT widget displays all the taxonomies, and even shows correctly in the sidebar the existing terms (links to click to drill down). But when I click any of the links I get the Nothing Found message on a page with the correct rewrite URL for that term (it's not the same as the link I clicked which has query variables). I've tried it without "Custom Post Archives" with the same result. I looked at the rewrites array and it looks like it should be generating the same syntax as the QMT links have.

    Example: click on QMT link of http://localhost/testsite?feature=edible
    and get Not Found page with URL http://localhost/testsite/feature/edible/

    Does it sound like a rewrite problem or does the custom post type have to be passed in? (I don't remember doing this before, but I might not have tested it with a custom post type.)


  2. scribu
    Plugin Author

    Posted 5 years ago #

    It doesn't look like a URL problem at all.

    Most likely, you're messing with WP_Query somehow in one of your templates.

  3. Joy
    Posted 5 years ago #

    So if I haven't made any modifications to the templates, and it doesn't work on TwentyTen either, do you mean that one of the other plugins could be messing with the query? What do I look for?

  4. Joy
    Posted 5 years ago #

    After some testing, I determined that it must be "Ultimate Post Type Manager" that is causing the problem. If I deactivate that and use "More Types" instead, QMT works as advertised. But only if I first use "Custom Post Archives" and tell it to be active and in the blog (so the custom post type shows up).

    So, if I mess with the query so that it sorts alphbetically, will it cause QMT to quit working?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Query Multiple Taxonomies
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic