Support » Plugins and Hacks » [Plugin: qTranslate] WordPress 2.5 compatibility

[Plugin: qTranslate] WordPress 2.5 compatibility

Viewing 15 replies - 16 through 30 (of 33 total)
  • I think I found a small bug.

    When you edit a post that has brakes inside (br) qTranslate doubles the brakes. When you save again, each line separated by brakes is turned into a paragraph.

    I have found some bugs.

    1) Recognition for title of Categories are lost.
    I run qt 1.1.0 on my blog http://www.japan-sweden.com and I run three languages….english..swedish and japanese.

    In one block (Categories) I enter title in three languages. It works perfekt for a while, but then when you add or modify any widgets, the setting is lost and only the default language is shown for the title “Categories”. It still works to switch languages, and all other titles changes, but “Categories” remains set to the default language.

    2) Blogroll
    When you add a link, you enter the title of your choice in Manage/Links/Add links, with the code [lang_en]English text[/lang_en][lang_sv]Swedish text[/lang_sv][lang_ja]Japanese text[/lang_ja]. After saving your link, when you go to the live site, the title for your link just shows title in all language including the language tags….

    3) Calendar does not change language.
    On qt 1.0.3, which I have on http://www.japantea.se/blog the title “Calendar” in Calendar changes when you change the language. But with qt 1.1.0, language does not change in the calendar (compare with http://www.japan-sweden.com).

    4) Flags does not appear.
    On qt 1.0.3 flags appear in the language chooser. With Qt 1.1.0, I cannot get flags to appear. Please compare http://www.japantea.se/blog with http://www.japan-sweden.com

    This was my five cents.

    Best Regards,

    Hi everybody!

    does anybody know how to translate the home name in menu?

    it´s possible to call different sidebars according the language choosed? how?

    it´s possible to specify different tag for each language? how?

    best regards,


    questions 1 and 2 were solved… now i´m trying to solve the TAG problem.

    does anybody knows?

    Hi morgan,
    For everones references, please post your solution that you found on how to solve the problems. There are propably more people that had similar problems as you. 
    Setting the language title for sidebars and blog title and home is not that difficult. Here is my solution for it...at least it works for me...
    Sidebars and blog title:
    When logged into the administrators area on your wp, insert the following code in the field for the title (you  find this in the user options settings) and for the sidebar (go to widgets)
    just surround the text you want inside the 'language' tags as follows:
    [lang_en]English text[/lang_en][lang_sv]Swedish text[/lang_sv][lang_ja]Japanese text[/lang_ja]
    lang_en = English, lang_sv = Swedish, etc 
    Please note that the tags need to be opened and closed properly, ie. [lang_xx] should be closed by [/lang_xx]
    For "Home", it is basically same code that you need to enter, but you need to insert this in the php-files. You edit header.php
    below <div class="navigators">
    You can insert a code like below:
    • <a href=”<?php echo
      get_settings(‘home’); ?>”><?php echo qtrans_useCurrentLanguageIfNotFoundUseDefaultLanguage(‘[lang_en]Home[/lang_en][lang_sv]Hem[/lang_sv]
      [lang_ja]ホーム[/lang_ja]’); ?>
    • `

      Is there anyone that knows how you make the flags appear. Please see my site http://www.japan-sweden.com

      As you can see in the language bar to the top left, there is no flag icon….and I want the flag icons to show….if there is anyone that knows how to do this, please post your solution here.

    Hi Bear3556!

    you can find the answer of how to show flags here:

    You just have to find these code:


    and change $type to both (to show flag and name) or image(to show just flags)

    Hi Morganfardo,
    Thank you for your post. I have read the instructions on the developers home page, but I still do not understand what file to find this code in…..I do not find it in qtranslate.php nor in the other php-files that comes with qtranslate 1.1.0.

    It this code somewhere else?

    If you could give me some example or and information on what file to look in, maybe that would help me to understand.

    Thank you very much for your support.

    Best Regards,

    i just add this <?php echo qtrans_generateLanguageSelectCode('image'); ?> in my header theme file.

    in your case you should add it in the sidebar…

    does anybody knows why my flags is all together? before they hava a space between them, and I did´t change any code in the qtranslate file.

    First off, thank you Qian for a truly amazing plugin!
    I’m using it with WP 2.5.1 and it works like a charm… except for one thing.

    Everytime I specify a custom permalink structure i.e /%postname%, I get a 404 error. I’ve managed to make the default language work by using index.php/%postname% as permalink structure but still, the 404 error page apears when i switch language.

    Is this a common problem or is it just my incompetence? I’ve even tried it on different hosts but no change. Any clues?


    Hi Morganfardo,

    Thanks for the advice. Just to confirm before I try….

    so you mean the following code should be placed in my sidebar.php

    <?php echo qtrans_generateLanguageSelectCode(‘image’); ?>

    or should it be

    <?php echo qtrans_generateLanguageSelectCode(‘both’); ?>

    in order to show both flag and text?

    Where in the sidebar.php should it be placed?

    Hello Morganfardo and everybody else,
    I have managed to get the flags appear in the sidebar but not within the qtranslate language chooser object.

    Please see http://www.japan-sweden.com

    I guess, the trick is to find where the qtranslate language chooser object is and then insert same code inside.

    For this I need find where this object is…

    Does anyone know where to find it? Any suggestion or ideas are highly appreciated.

    Dear Morganfardo,
    I have solved the flag-problem. I could not find where to insert the code in the sidebar, so I altered the code in qtranslate_wigdet.php

    Maybe this is not how it should be, but at least it works for me.

    If anyone want to see the code that I altered, please post a request and I will post the code.

    I also want to apologize on beforehand to the creator of qtranslate for altering the core code without prior permission. I tried to contact to receive your help on how to solve the issue in a conventional way. As I did not get any response, I needed to manipulate the code in a more inconventional way.

    Best Regards,


    I have just one questions/problem:

    I need to use some tags like [lang_xyz][/lang_xyz] inside my single.php file. Is there some kind of code for something like that?

    I need this because I have some Custom Fields and need to get them translated in template file.

    Here is example what I try but that doesn’t work:
    <p>[lang_en]<strong>English text</strong>[/lang_en] [lang_de]<strong>Deutsch text</strong>[/lang_de]<?php meta(ad_xyz); ?></p>

    Thanks for any help

    Few more details:

    I try this code:
    <?php_e('[lang_en]english text[/lang_en][lang_de]german text[/lang_de]'); ?>
    and I get: Fatal error: Call to undefined function php_e() in

    When I try almost same code from FAQ page ofQTransate:
    <?php _e(’[lang_en]english text[/lang_en][lang_de]german text[/lang_de]’); ?>
    I didn’t get any errors but I didn’t get any text also.

    If You don’t see difference, it is between –>'<– and –>’<– signs.

    Everything else is working beautifully, for now.

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘[Plugin: qTranslate] WordPress 2.5 compatibility’ is closed to new replies.