WordPress.org

Support

Support » Plugins and Hacks » [Plugin: qTranslate] WordPress 2.5 compatibility

[Plugin: qTranslate] WordPress 2.5 compatibility

Viewing 15 replies - 1 through 15 (of 33 total)
  • Hi,

    I also use qTranslate 1.0.2 on my blog (http://bamako.secureweb.hu) and I also have the same problem. When I activate the plugin the content that is already multi-lingual shows up properly, but the editor doesn’t show up at all. When I deactivate the plugin I get the raw data on the site with the [lang_xx] tags, and the editor works.

    As a quick workaround, so I could still post on the blog I modified the wp-content/plugins/qtranslate/qtranslate.php and commented the line
    add_filter('the_editor','qtrans_modifyRichEditor');
    on line 1651.

    This way I’m able to show my multi-lingual content as usual, and also I’m able to use the original editor. However to have multi-lingual content I have to add the [lang_xx] tags by hand to both the title and the content.

    I hope to have this issue resolved and the plugin will be upgraded to 2.5 compatible, because I liked the editor it had.

    I agree with submarine – great plugin!

    Thanks for the hack csak – that’s good to know.

    I see this on the plugin page:

    Is WordPress 2.5 supported?
    No, it isn’t. I will be, but not in the close future. So if you want to use qTranslate, you will have to stick with 2.3.3 for a while.

    It would be great to have a rough idea when WordPress 2.5 will be supported.

    Many thanks

    we’re just starting a project site, and not having WP 2.5 support means that we just have to live without this pluign 🙁

    would have been great though…

    It’s a great plugin. Many people were waiting for. We’d love to use it for WP 2.5.

    Please don’t make us wait for a long time.

    Many thanks

    I second that; it all started off beautifully with this plugin and then I found it’s not supported under 2.5. A real shame and it’ll cost me a lot of extra work to manually create language-seperate-categories etc..
    I’ll have a look what’s causing the problem with the editor

    hi guys,

    i’m been really busy with my exams lately. If you take a look at the code, the editor modification is basically all heavy javascript. WP 2.5 is much harder to code because it has a lot of new functions with I need to change manually. It’s not like I don’t want to use WP 2.5 on my site, I can’t wait to upgrade, so all I can say to you guys is: please wait patiently.

    But if you guys like the plugin that much, consider supporting the plugin. I’d like more language to be included by default, but I don’t speak that many languages perfectly. 😉

    hi chinesleper,

    Thanks for the update and all the work you’re putting into this. Imho qTranslate is _the best_ multi-lingual tool available for wordpress, so i’d love to use it.
    Can you elaborate on what exactly you’d need done from us in order to translate to a specific language?
    I have some experience with translations to/from Dutch if you need that language

    Robert

    I need: (Example)
    Native Language Name (English)
    Locale (en_US)
    Not Available Message (Sorry, this entry is only available in %LANG:, : and %.)
    Time Format for strftime (%I:%M %p)
    Date Format for strftime (%A %B %e%q, %Y)
    Flag Image file name included with qTranslate (gb.png)

    I will mention who submitted which language in the source code. It’d be best if only native speakers submit data.

    Dutch

    Native Language Name (Nederlands)
    Locale (nl_NL)
    Not Available Message (Onze verontschuldigingen, dit bericht is alleen beschikbaar in %LANG:, : en %.)
    Time Format for strftime (%H:%M)
    Date Format for strftime (%d/%m/%y)
    Flag Image file name included with qTranslate (nl.png)

    Finnish

    Native Language Name (Suomi)
    Locale (fi_FI)
    Not Available Message (Pahoittelemme, artikkeli on saatava vain %LANG:, : ja %. kielellä)
    Time Format for strftime (%H:%M)
    Date Format for strftime (%d/%m/%y)
    Flag Image file name included with qTranslate (fi.png)

    forgot to mention:

    I cannot wait qTranslate to support 2.5.x. The Plugin is pure gold!

    Basque

    Native Language Name (Euskara)
    Locale (eu_ES)
    Not Available Message (Barka, baina sarrera hau hizkuntza hauetan dago soilik: %LANG:, : eta %.)
    Time Format for strftime (%H:%M)
    Date Format for strftime (%y/%m/%d)
    Flag Image file name included with qTranslate (eu.png)

    Please note that “eu” is the ISO 639-1 Code for Basque, not for “Europe”.
    Thanks for the great plugin, we’re all waiting for the 2.5-compatible version!

    I released a WP 2.5 compatible version, which should work just fine. Further testing is still needed though.

    @robv
    In the next development version, I added Dutch. I’ll need your real name for credits though.
    @boxhead
    Finish has already been included in older versions, please take a look in the qtranslate.php file to check if the content is correct.
    @gari
    As for Basque, I’ll need the flag name for the flag included with qtranslate, not the iso code. eu.png is the european flag. I’ll need your real name as well.

    Hi chineseleper,

    thanks for the immediate WP 2.5.1 support. Today I installed your qtranslate 1.1 update and it seems to run fine. Some more testing is required. Excuisite work! One hint: The french unavailable phrase sais:

    Désolé, cet article n´est pas disponible en …. but it should be:
    Désolé, cet article n´est que disponible en …. or
    Désolé, cet article est seulement disponible en …..

    Thanks again for the great work

    Roland

    I Chinesleper,
    Thanks for the great plugin. I am swedish and can give you the swedish words in order to integrate swedish in next update….

    Native Language Name (Svenska)
    Locale (sv SE)
    Not Available Message (Tyvärr är denna artikel enbart tillgänglig på %LANG:, : och %. )
    Time Format for strftime (%H:%M)
    Date Format for strftime (%d/%m/%y)
    Flag Image file name included with qTranslate (se.png)

    By the way, I have problem with the plugin. I cannot get the flags to show propably even though all links seems to be OK. Can you give me any hint for how to solve this?

    I am looking forwards to hearing from you within soon.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Plugin: qTranslate] WordPress 2.5 compatibility’ is closed to new replies.
Skip to toolbar