Support » Plugin: Qtranslate Slug » [Plugin: Qtranslate Slug] 404 Not Found error

Viewing 12 replies - 1 through 12 (of 12 total)
  • Error message:
    This is somewhat embarrassing, isn’t it?
    It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.

    This happens when I use the qTranslate slug plugin. If I take it away, everything goes well.

    Is there any way to fix it?

    I have wordpress 3.3.2

    Thanks

    Plugin Author Carlos

    (@carlos_a_sanz)

    Sorry, i didn’t upload any documentation because version 1.0 is almost finished.

    That happens because you need to regenerate wp_rewrite. In administrator try to navigate to Settings/Permalinks, and save.

    if you’re using custom post types, when you register a post type, call this function flush_rewrite_rules(). Something like:

    function my_post_type() {
          register_post_type( $post_type, $args );
          flush_rewrite_rules()
    }
    add_action('init', 'my_post_type');

    If still no working, wait to version 1.0 (completely rewritten).
    Greetings.
    C.

    Thank you for this plugin, i’m waiting also the 1.0 version.
    Actually, it doesn’t works for me, i’ve put the permalinks to /%postname%/ and it doesn’t found the english link…
    regards

    Plugin Author Carlos

    (@carlos_a_sanz)

    New version 1.0 uploaded. Compatible with wordpress 3.4🙂

    Hi Carlos, thank you very much, it’s working, except when i generate a new sitemap with “Google XML Sitemaps v3 for qTranslate”, all the sitemap links are wrong!!!

    Another thing: the qtranslate widget translator you changed is not aligned, the flags are riding themselves!!!

    Plugin Author Carlos

    (@carlos_a_sanz)

    Hi,
    i will try to do some integrations with other plugins and add support to multisite in next minor versions, thanks for report!

    C.

    Carlos: thank you for the update, but I found a bug which is important for me:
    without qtranslate slug plugin my permalinks looks like:
    example.com/en/accommodation/

    with the plugin
    example.com/en/category/accommodation/

    I tried everything to remove the “category”, but it with the plugin it is imposibe. Can you put a remove “category” or “tags” field option in the next update?

    Plugin Author Carlos

    (@carlos_a_sanz)

    Hi,

    in your case, accommodation wich kind of content is?

    Normally the categories/tags/taxonomies follows this structure:

    > example.org/taxonomy-base/your-taxonomy

    But if you’re using some plugin or theme that changes the normal permastructs, the plugin will not works.

    Greetings!

    Hi,

    accomodation is a category, I removed the category slug with “No Category Parents” plugin so thats why I got the following result with 0.9:
    example.com/en/accommodation/

    With the version 0.9 it works correctly, but after the update the category slug appears. So my solution was the downgrade (and waiting for a fix 🙂 )

    Plugin Author Carlos

    (@carlos_a_sanz)

    Ok,

    Qtranslate Slug 1.0 uses $wp_rewrite for change the permastructs, that happens because this plugin should modifies the permastruct too. For fix that i need to add support, i aim No Category Parents in the adaptations list.

    Thanks for the plug in Carlos, it actually help me giving me the option to translate the categories but the thing now is when I click on the category translated to Spanish it shows page not found but when category is in default language (English) it goes to the categories page just fine. any suggestion would be greatly appreciated.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Qtranslate Slug] 404 Not Found error’ is closed to new replies.