Support » Plugin: Q&A » [Plugin: Q&A] Answers don't allow certain HTML tags

  • I finally got the Q&A plugin to look ok within the Karma theme. I’ve been testing Q&A and noticed that no matter what I do, I can’t seem to successfully post an Answer that has a line-break or paragraph <p> in Visual mode. When I create an answer in visual mode that have these, after I post, all text is on the same line. I look at the source and no HTML. The text looks right in Visual view and when I switch over to HTML view, it looks the same as on Visual mode (no HTML code) but is properly formatted right. I have tried installing 2 other editors, but same issue.

    When posting a question, it works fine. I have tried turning all my plugins off, tried the 20/10 theme, tried a “Enable RAW HTML” plugin, still nothing. I have even tried re-creating the single-question.php file. I am using Visual mode because everyone who will be posting both questions and answers is not going to know HTML code. Can anyone suggest a fix/direction? Site is inspir3 DOT COM / questions. The answers you see there have been edited in through the admin for formatting the paragraphs.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I am also getting same. Not able to see WYSIWYG editor.

    it’s sound like a Jquery conflict.

    Normally tinyMCE editor in WordPress relys on wpautop to output line-breaks, check if wpautop has been disabled.

    I don’t have the know-how to fix a jquery conflict. I tried commenting out the wpautop, but it’s still happening.

    Ok Finally I am able to see WYSIWYG editor after disabling CFORM plugin.

    Now If I post any questions it will display properly along with paragraph aliened. But If I put any answers to the questions, there is no paragraph alignment. It will display continuously.

    I think this is some CSS problem. I am not able to identify.

    Yes, it only happens when posting an answering.

    I don’t have line-break issue with answers, so I guess this is theme&plugins related.
    @ranjith are you sure the p tag exists but can’t break line? If this is the case maybe it needs a width or even word-wrap property.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Q&A] Answers don't allow certain HTML tags’ is closed to new replies.