Q2W3 Post Order
Q2W3 not working for all posts (6 posts)

  1. williamwm
    Posted 3 years ago #


    I have been using the plug-in for one of the sites I am administrating and have very mixed results using it.

    Sometimes everything works fine for a few weeks, and suddenly a few posts refuse to stay in the position we have designated.

    At the moment, we are trying to order six posts on the front page. This is the list as designated in the Q2W3 Post Order plug-in:

    # ID Title
    1 596 Take Shelter
    2 710 From the back of the room
    3 571 Babycall
    4 574 Elena
    5 577 Barbara
    6 600 Ai Weiwei Never Sorry

    But on the front page the following order is displayed:

    # ID Title
    1 596 Take Shelter
    2 571 Babycall
    3 574 Elena
    4 577 Barbara
    5 600 Ai Weiwei Never Sorry
    6 710 From the back of the room

    Using WP 3.4.1 and Q2W3 Post Order 1.2.4

    I have tried all I can think of:
    * Re-assigned the order of the posts
    * Emptied all Cache for the website
    * Tried to move the problematic post around (tried other positions other than second post)

    I have as well removed all other plug-ins that changed something on the front page, Q2W3 is the only front page focused plug-in.

    Any ideas?

    And as I said, this issue pops up from time to time.


  2. Max Bond
    Plugin Author

    Posted 3 years ago #


    You can enable debug mode. See general options on the plugin page.
    Debug data will appear on the front page for registered administrator.

    You can send this data to me from this page: http://www.q2w3.ru/contacts/

  3. williamwm
    Posted 3 years ago #

    Thanks! Much appreciated!

    I have sent the debug data to you.

  4. williamwm
    Posted 2 years ago #


    I understand if you have a lot to do (and are providing this plugin for free), but I have yet to receive a response from you about our issue.

    The issue keeps occurring intermittently and this is the only plugin that works most of the time.

    Any help is very much appreciated!

  5. williamwm
    Posted 2 years ago #

    The problem is still that the posts are displayed in ID order, not in the order specified in Q2W3 Post Order.

    We are not ordering the posts within their categories, but doing the ordering by "Post type" Posts.

    We have tried doing it for the categories instead, but to no avail.

  6. Max Bond
    Plugin Author

    Posted 2 years ago #


    Sorry for bad support...

    Well, I recieved debug data, but didn't find any problems.

    I need more info. Can you send me your theme files or give an access to your site?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Q2W3 Post Order
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.