WordPress.org

Support

Support » Plugins and Hacks » Q and A FAQ and Knowledge Base for WordPress » [Plugin: Q and A – FAQ Plugin] [qa cat="slug"] only showing five items

[Plugin: Q and A – FAQ Plugin] [qa cat="slug"] only showing five items

Viewing 15 replies - 1 through 15 (of 18 total)
  • same happening for me… never noticed it before until a few minutes ago. I can re-order the FAQ items and but it only shows the first 5. Please help!

    Does the number shown change if you change “Blog pages show at most” setting? That would be the setting found on Dashboard >> Settings >> Reading.

    @macdoodle: Those were set to ten, but I’m only showing five each on the page, so I don’t believe this is relevant.

    Chris, same thing here…it’s not a posts per page setting issue..it’s something else.

    Plugin Author Dalton Rooney

    @daltonrooney

    I wonder if you could post your theme and list of plugins here, since this isn’t a general problem with the plugin, it seems to only happen to some people.

    You could start by deactivating your plugins one by one, and then switching back to the default theme. At some point all of the FAQs will be shown again, and you’ll have identified the culprit. Maybe there’s a way to work around it if I know what is causing the conflict.

    Regards,
    Dalton

    I’m using a modified version of Elegant Themes’ Minimal theme, version 3.4, on WordPress 3.3.1

    Even with EVERY plugin disabled except for Q & A, I only get five items. I’d even be willing to give you a temporary login, if you think you might learn more that way. Give me your email and I’ll PM you info.

    Plugin Author Dalton Rooney

    @daltonrooney

    Hi Cris,
    What happens when you temporarily switch back to the default theme? It sounds like there’s something weird in the Elegant Themes template that is causing a problem with Q & A.

    It would actually be best if you could send me a zipped copy of your theme. That way I can experiment with it without the possibility of breaking your site. If you want, you can send it to dalton [at] madebyraygun.com

    Cheers,
    Dalton

    @cris & @tmcguire — there was a different faq plugin that had the same problem (saw it in the forum) and changing that setting had some effect… which is why I asked.

    The person posting at the link below was having the same sort of problem.
    http://wordpress.org/support/topic/only-showing-5-posts?replies=9

    The fix was about using “query_posts” instead of “get_posts” in the loop, and then using a secondary loop… which is the fix I think the plugin needs.

    Another thing to check — does your theme have the wp_footer() tag in in place?

    Definitely this problem is related to the theme. When I switch to Twenty Eleven, the problem is gone, and it returns as soon as I switch back to the elegant themes. I’m emailing you the theme, Dalton. I’ve tried both the default page template and the full width, with identical results, so I’m guessing the issue is probably in the loop somewhere. Thanks for looking into this!

    Plugin Author Dalton Rooney

    @daltonrooney

    MacDoodle, thanks for the tip. I’ll look into that and if it fixes the problem I can post an update pretty quickly.

    Dalton

    I’ve found a solution to this problem. When using any Elegant Themes theme, they have a setting on the ePanel General Settings tab which limits the number of posts on Archive pages (ET has settings for other listing groups, too…). I removed the number from that field, saved my changes, and the problem is gone.

    If you’re using these themes or any premium themes that have a lot of admin settings, look for a similar setting and remove it, and your FAQ sorted by categories should show correctly!

    *applause*

    Plugin Author Dalton Rooney

    @daltonrooney

    If anyone wants to give it a try, the development version should have a fix for this. Try downloading it from here: http://wordpress.org/extend/plugins/q-and-a/download/

    Plugin Author Dalton Rooney

    @daltonrooney

    Did anyone take a look at the development version to see if the changes fix the problem for them? I’d like to hear yes or no from at least a couple people before I publish the next version of the plugin.

    I’m using Elegant Themes Evolution theme, and just tried the version at that link. Seems to work the same. I removed the “archive” posts number from the ET ePanel Settings, but then it reverted from being limited to 5 (which was in the ePanel settings) to being limited to 10 (which is what the global WP setting is set to).

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Q and A – FAQ Plugin] [qa cat="slug"] only showing five items’ is closed to new replies.
Skip to toolbar