Support » Plugin: Pronamic Google Maps » [Plugin: Pronamic Google Maps] Custom post types question

  • Resolved zanzaboonda


    Okay, so I see in the description it says it works with custom post types. I’m not a coder; I only know a little bit. But if someone can point me in the right direction as to where to find the information, I would be so happy. 🙂

    I am currently using WP Business Directory Manager Plugin (, which I really like except that they upgraded to these custom post types and now MapPress doesn’t work with it anymore. 🙁

    So I’m just wondering how and where to implement the code provided for PGM to get it to work with the custom post type for WPBDMP.

    In the plugin’s main .php file, I see this:


    But I honestly can’t find a logical place where it seems like I should put the code (e.g., for the Google Maps Mashup):

    if(function_exists('pronamic_google_maps_mashup')) {
                'post_type' => 'post'
            ) ,
                'width' => 300 ,
                'height' => 200 ,
                'map_type_id' => 'satellite' ,
                'marker_options' => array(
                    'icon' => ''

    Can anyone tell me where I should put it or what I might be looking for?

    Thanks and best wishes,

    (I might be upgrading my WP installation later today.)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Remco Tolsma


    Just go to the Pronamic Google Maps settings in your WordPress admin interface and activcate Google Maps for you custom post types. You only have to check an checkbox to activate Google Maps for custom post types.

    Hi Remco-

    Thank you for the prompt response!

    And brilliant, thanks. 🙂

    I’m still a little confused on one point, though. Do I still need to add that code in somewhere? I did the checkbox and it displays fine in the editor, but not upon publishing.

    I read the other post about it not showing up and tried to add the code to the loop.php file beneath the <?php the_content(); ?> code and

    	'width' => 290 ,
    	'height' => 200

    beneath the get_template_part(‘content’, ‘page’);.

    But neither of these seemed to work, so I deleted them again…

    Is there something I am missing? So sorry to be a bother.

    Thanks again and best wishes,

    Plugin Author Remco Tolsma


    Yes, you also need to add code somewhere:

    De adjustment you describe should normally work correct. You could try to add the following code to your functions.php file:

    if(function_exists('pronamic_google_maps')) {
        function custom_pronamic_google_maps_the_content($content) {
            $content .= pronamic_google_maps(array(
                'width' => 500 ,
                'height' => 500 ,
                'echo' => false
            return $content;
        add_filter('the_content', 'custom_pronamic_google_maps_the_content', 9);

    If that is also not working you should check if you have an wp_header() functioncall in header.php and an wp_foot() function call in footer.php. Otherwise you could pass us an URL of an page where the map is not showing up.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Pronamic Google Maps] Custom post types question’ is closed to new replies.