[resolved] Fatal error: Cannot access empty property (3 posts)

  1. Chris
    Posted 5 years ago #

    When adding a new dataset, I see the following message:

    New dataset added to the database.

    Fatal error: Cannot access empty property in /... etc. .../wp-content/plugins/projectmanager/lib/core.php on line 888

    After that, I cannot even access the Overview page.
    This happens with version 2.9.8.


  2. projectmanager_bugreport
    Posted 5 years ago #

    This happened for my projectmanager case, too.
    However, it first occurred right after upgrading from 2.9.7 to 3.0.3 (including the database migration thereafter).

    The code works now, after I manually edited lib/core.php around line 932, where the error was caused.

    In my edited version, that loop now looks like this:

    foreach ( $meta AS $m ) {
    				$key = sanitize_title($m->label);
    				if($key != null && $key != "")
    				{$dataset->{$key} = $m->value;}

    So I just added the "if" conditions.
    The php interpreter cannot again be stuck in the assignment with an empty property.

    Time for another Bugfix? Or my issue only?

  3. dlfadmin
    Posted 5 years ago #

    Had the same issue as well, your workaround fixed it nicely. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • ProjectManager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic