WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [Plugin: Posts 2 Posts] Update to 1.1.4 causes errors in WP v.3.2.1

[Resolved] [Plugin: Posts 2 Posts] Update to 1.1.4 causes errors in WP v.3.2.1

  • I just updated P2P to 1.1.4 and I’m getting the following output before the theme renders:

    Backtrace from warning 'Connection types without a 'name' parameter are deprecated.' at /home/sketchy/public_html/wp-content/plugins/posts-to-posts/core/api.php 59:
    
        /home/sketchy/public_html/wp-content/plugins/posts-to-posts/core/api.php 59 calling trigger_error()
        /home/sketchy/public_html/wp-content/themes/TOsketchfest/functions.php 85 calling p2p_register_connection_type()
        calling my_connection_types()
        /home/sketchy/public_html/wp-includes/plugin.php 405 calling call_user_func_array()
        /home/sketchy/public_html/wp-settings.php 302 calling do_action()
        /home/sketchy/public_html/wp-config.php 93 calling require_once()
        /home/sketchy/public_html/wp-load.php 29 calling require_once()
        /home/sketchy/public_html/wp-admin/admin.php 30 calling require_once()
        /home/sketchy/public_html/wp-admin/plugins.php 10 calling require_once()
    
    Backtrace from warning 'Connection types without a 'name' parameter are deprecated.' at /home/sketchy/public_html/wp-content/plugins/posts-to-posts/core/api.php 59:
    
        /home/sketchy/public_html/wp-content/plugins/posts-to-posts/core/api.php 59 calling trigger_error()
        /home/sketchy/public_html/wp-content/themes/TOsketchfest/functions.php 91 calling p2p_register_connection_type()
        calling my_connection_types()
        /home/sketchy/public_html/wp-includes/plugin.php 405 calling call_user_func_array()
        /home/sketchy/public_html/wp-settings.php 302 calling do_action()
        /home/sketchy/public_html/wp-config.php 93 calling require_once()
        /home/sketchy/public_html/wp-load.php 29 calling require_once()
        /home/sketchy/public_html/wp-admin/admin.php 30 calling require_once()
        /home/sketchy/public_html/wp-admin/plugins.php 10 calling require_once()

    I’ve had to deactivate the plugin, which has undesirable results. I’m planning on updating to wo3.3, but I’d like to get this working again beforehand if possible.

    Any assistance would be appreciated.

    many thanks in advance.

    http://wordpress.org/extend/plugins/posts-to-posts/

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: Posts 2 Posts] Update to 1.1.4 causes errors in WP v.3.2.1’ is closed to new replies.
Skip to toolbar