WordPress.org

Support

Support » Plugins and Hacks » Posts 2 Posts » [Plugin: Posts 2 Posts] Error on Plugins Page

[Plugin: Posts 2 Posts] Error on Plugins Page

  • Hi there,

    After updating to 1.4.1 I’m seeing this error at the top of the Plugins page:

    Warning: get_object_vars() expects parameter 1 to be object, null given in /Users/jonahwest/Sites/jenny-green/sites/botham/acala/www/wp-content/plugins/posts-to-posts/core/side.php on line 83

    It seems like everything is still working right but though I should report this anyway.

    Thanks,
    Jonah

    http://wordpress.org/extend/plugins/posts-to-posts/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author scribu

    @scribu

    I don’t see it.

    It’s very peculiar that it shows up only on the plugins page for you.

    This problem arises when at least one of the connected post type does not exists.

    @jonahcoyote,
    Please check if all the connected post types exists. If they do, then you may want to hook the function in which you are registering connection to a late action like wp_loaded.

    I’m using 1.4.2 and I am receiving the same error. My post types exist, ‘pages’ to ‘products’, I’m hooked into ‘wp_loaded’. I see the connection in my dashboard under tools>connection types but I don’t get any new metaboxes in either my ‘Products’ or ‘Pages’ new-post editor and I’m getting the above-referenced error in my log. Any tips?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Posts 2 Posts] Error on Plugins Page’ is closed to new replies.
Skip to toolbar