Posts 2 Posts
All connections gone after update to 1.4 ? (13 posts)

  1. twoworlds
    Posted 3 years ago #


    today I updated a website which is using p2p 1.3. After the update, it seems, that all connections are lost. I can see the admin box, but the connected items are empty (I only use 1 connection one-many between pages and a custom post type).

    In the frontend I get the following error:

    Warning: Queries without 'connected_type' are no longer supported. in /wp-content/plugins/posts-to-posts/core/query-post.php on line 16

    Using 1.3, everything worked fine. I can see, that there are some entries in p2p table in the database, so it seems, that my data is there. What am I doing wrong ?


  2. twoworlds
    Posted 3 years ago #

    I checked a few things, my connected_type is set correctrly and the column 'p2p_type' shows the correct name.

  3. iHuman
    Posted 3 years ago #

    I'm having the same issue...

    hopefully we will get it resolved soon

  4. iHuman
    Posted 3 years ago #

    let me clarify this...

    the connections are NOT gone. They are in the database. They function correctly in the code to generate data on the front end. They are just not showing up in the metaboxes for each CPT.


  5. iHuman
    Posted 3 years ago #

    upgraded to the development version 1.4.1 - and all is good ;)

    @twoworlds - if you haven't done that yet, you might want to try this as well.

  6. twoworlds
    Posted 3 years ago #

    @iHuman - I already updated to version 1.4.1, no change.

    The connections are in the database (as far as I can tell), but they don't appear in the admin box and the frontend code gives me the error above.

    I read some threads where this happened in case the connected_type wasn't set and the system genrated a hash value. But I have set the connected_type and the connections in the database show the correct value in p2p_type column.

  7. twoworlds
    Posted 3 years ago #

    My p2p_register_connection_type: http://pastebin.com/jcHiaUtX

    And the query I use: http://pastebin.com/AihZHr4U

  8. Francois Lamotte
    Posted 3 years ago #

    Hello @twoworlds,

    there is an indication by @scribu here on another thread

    I've got the same problem... will try to operation tonite. Cross my fingers.

  9. Francois Lamotte
    Posted 3 years ago #

    The info is maybe outdated (4 months ago) even if the problem seems similar.

  10. twoworlds
    Posted 3 years ago #

    Hi Francois,

    this didn't help me. I reverted back to version 1.3.1 and all connections are there and everything works fine. I also tried 1.4.1 but that didn't solve the problem.

  11. 2046
    Posted 3 years ago #

    I have the same problem..

    I have set up the connections.
    All the connections are visible in admin area.
    But once I want to show the connections on the front end the output is Warning: Could not find direction(s). in ....www/wp-content/plugins/posts-to-posts/core/query-post.php on line 16

    What I found out is that the error is there only for second, third and other calls (Xth connection type), not the first one.
    I tried to change the order if the connection is are not wrongly set up, but not, they are fine.

    If Scribu needs the direct access to the website to see what's going on, I'll send it to him.

    UPDATE: the solution is here http://wordpress.org/support/topic/warning-could-not-find-directions-line-16?replies=3

    The reason is that we have to explicitly specified the connection direction
    'connected_direction' => 'to',

  12. scribu
    Plugin Author

    Posted 3 years ago #

    @2046: If you would have looked at the support threads, you would have seen this thread:


  13. 2046
    Posted 3 years ago #

    I was just typing the link to that solution.
    Thanks Scribu ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Posts 2 Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.