WordPress.org

Forums

Postie
[resolved] Invalid Sender even though the Sender is Authorized (11 posts)

  1. JakeThePeg
    Member
    Posted 4 years ago #

    I'm having this issue repeatedly on 3.0.1. Postie will not pick up emails from the designated inbox, regardless of the settings I have on the "User" tab of the Postie Administration.

    I have tried setting the "Allow anyone to post via email" to "Yes", and adding the sender email addresses to the "Authorized Addresses" box, and it still won't work.

    It just comes up with the same message as I see below.

    Any ideas what the issue might be?

    Checking for mail manually
    This is the postie plugin
    time:1288079990
    Revision: 254232
    Last Changed Date: 2010-06-11 14:39:35 -0400 (Fri, 11 Jun 2010)

    Connecting to mail.xxxxxxx.com.au:110 (pop3))
    Mission complete, message 1 deleted.
    memory at start of e-mail processing:17612048
    Confirming Access For xxxx@xxx.com.au
    Invalid sender: xxxx@xxx.com.au! Not adding email!
    A copy of the message has been forwarded to the administrator.
    Ignoring email - not authorized.
    memory at end of e-mail processing:17621244

  2. stevehaslip
    Member
    Posted 4 years ago #

    I am having the exact same issue. I can get Postie to post from one email address, the admin of the blog, but not a second email address. I created a wordpress author account with the second email address I added to Postie (which I know you don't need to do) but it still rejects the email post from anyone other than the first email address I entered.

    Again, I'm using wordpress 3.01 and Postie 1.41

  3. leodrink
    Member
    Posted 4 years ago #

    我也是相同的问题~~求解答

  4. leodrink
    Member
    Posted 4 years ago #

    Checking for mail manually
    This is the postie plugin
    time:1289361436
    Revision: 254232
    Last Changed Date: 2010-06-11 14:39:35 -0400 (Fri, 11 Jun 2010)

    Connecting to pop.163.com:110 (pop3))
    Mission complete, message 1 deleted.
    memory at start of e-mail processing:20445344
    Confirming Access For xxxxxx@ourcos.cn
    posting as user 1 Invalid sender: xxxxxx@ourcos.cn! Not adding email!
    A copy of the message has been forwarded to the administrator.
    Ignoring email - not authorized.
    memory at end of e-mail processing:20459264

  5. wynntom
    Member
    Posted 4 years ago #

    I have having the same problem as all of you:

    Confirming Access For xxxx@xxxx
    Invalid sender: xxxx@xxxx! Not adding email!
    A copy of the message has been forwarded to the administrator.
    Ignoring email - not authorized.
    memory at end of e-mail processing:31495104

    I have added that email to the authorized senders list. I've even set the "Allow Anyone to Post via Email" option to YES (I created an insanely long email address), and still the sender is unauthorized.

    I tried uninstalling the plugin, then installing it again. No go.

    I'm kinda tired of trying to make this work. This is quite the drag. Have any of you made any progress?

    Thanks,
    Tom

  6. Siberian
    Member
    Posted 4 years ago #

    I just went through a couple hours of banging my head with this plugin, and the cause of my problems was pretty dumb on my part. I'm using WordPress 3.01 and Postie 1.41 on a fresh install (no extra plugins).

    The short answer is that the first thing I did when I got into Postie config was change the name of the admin on the USER tab of Postie. Where it says "Admin username: " the default is admin I think, but I changed it thinking that it was going to affect how the name appeared when it was posted to the site. In retrospect this was really dumb, but there it is. This must exactly match the name of the admin account on your site, especially if you are going to allow anyone to post.

    Some other observations.

    Run Test Config every time you update something in Postie config. My best guess is that if the test config is working, your problems are probably related to linking user accounts between Postie and WordPress.

    I have mine set up to accept all incoming emails under the USER tab. I want this because I have a variety of people from a variety of email accounts posting to my site, all aggregating into the admin account pending my approval before they appear live. However, I discovered that if I wanted a specific person to post via email and have it linked to a specific WordPress account I needed to use the check box to select that person's user group in "Roles that can post" (eg, Editor). Once I did this and included that user's email address in the Authorized Addresses, it seemed to work fine. Now anyone can post to my site, having it posted as admin. However, specific people are also set up to post to specific accounts at the same time.

    writers 1-50 send email anonymously, and are posted to the admin account
    writer 51 sends email and it gets posted with their WordPress name (his email is the only one in the authorized addresses list)

    Hope this helps someone.

  7. kkoechel
    Member
    Posted 4 years ago #

    here is a bad fix. The issue for me was my smtp headers weren't "correct" whatever that means.

    on lines 906 and 907 of postie-functions.php these lines exist:

    $validSMTP=checkSMTP($mimeDecodedEmail, $smtp);
    if (!$poster || !$validSMTP) {

    the way I fixed my problem was I changed like 907 to read:
    if (!$poster) {

    Sooooo.... like i said, terrible, but working!

  8. kris27
    Member
    Posted 4 years ago #

    I know this is an old post but Siberian you are a genius! I've been trying to figure that out for ages and now it works fine. I still get an error that comes up when I try to post but it still shows on my blog. I think it's an error on my host side rather than postie though.

  9. Kelly
    Member
    Posted 4 years ago #

    Thank you all for this great info. I have postie 1.4.2 on WP 3.1.3, network. On all of the networked sites postie is running fine but on one site no. I went through all things above mentioned. Symptoms are; when picking up email using the 'run postie' button I get a server error. After that if I go to posts, the last post is there but with 'tmptitle' for title and content is only 'tmpPost'. Same thing when running on auto. Strange that it would not work on just one site (3). I suspect maybe a plugin but don't want to turn off all of them. Guess I will have to give that a try.

  10. thegirlsgot
    Member
    Posted 4 years ago #

    HI Siberian,
    Thank you Thank you! I have been getting so frustrated with this plugin and couldn't figure out why it wouldn't worked because it has on all my sites. And couldn't find an answer until today. You fixed my problem I had admin and should of had my user name in it.
    Working great now
    again thank you

  11. medaguru
    Member
    Posted 4 years ago #

    WOW a simple little thing like a username....

    Siberian saves the day!

    Thanks man! as soon as I changed the user name back to admin it worked!
    I had to change it via PHP myadmin, Word Press won't let any changes to the username. ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Postie
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags