WordPress.org

Support

Support » Plugins and Hacks » PostgreSQL for WordPress (PG4WP) » [Resolved] [Plugin: PostgreSQL for WordPress (PG4WP)] Error adding a new category

[Resolved] [Plugin: PostgreSQL for WordPress (PG4WP)] Error adding a new category

  • Plugin Author hawk__

    @hawk_

    When your WP+PG4WP setup was done with PG4WP before 1.3.0b1, you may have an error message when creating new categories.

    This is because of a problem with WP creating categories with specifying the id to be inserted in the table wp_terms.

    PG4WP 1.3.0b1 introduces a filter to correct this problem when installing WordPress but if you just upgraded an existing installation you can resolve this particular problem by running the following SQL on your PostgreSQL database (using any tool you want) :
    SELECT setval('wp_terms_seq', (SELECT MAX(term_id) FROM wp_terms)+1);

    Note : you should replace wp_ with the appropriate table prefix if you changed it in your WordPress installation

    http://wordpress.org/extend/plugins/postgresql-for-wordpress/

  • The topic ‘[Resolved] [Plugin: PostgreSQL for WordPress (PG4WP)] Error adding a new category’ is closed to new replies.
Skip to toolbar