PostgreSQL for WordPress (PG4WP)
database cannot be selected at install (2 posts)

  1. kongo47
    Posted 3 years ago #


    I have encountered an error at the first step of installation using PG4WP.
    The message I had was that login info were correct but the database could not be selected.

    Config : PostGreSQL 9.1.2 ; PG4WP 1.3.0 ; PHP 5.1.3-RC4

    I solved this by manually editing pg4wp/driver_pgsql.php
    line 80 :
    return wpsql_select_db( 'template1');
    I replaced template1 by my database name and the problem was solved.

    PS : my blog is hosted on a subdomain of free.fr


  2. corgi
    Posted 3 years ago #

    I'm seeing the same thing on WP 3.4.1 on Fedora 17 using PHP 5.4.5 and pgsql-lib 9.1.4. Changing line 80 of pg4wp/driver_pgsql.php to the name of our database solved the issue.

    Edit: We're also using PG4WP 1.3.0.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • PostgreSQL for WordPress (PG4WP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.