WordPress.org

Support

Support » Plugins and Hacks » Posterous Importer » [Plugin: Posterous Importer] 403 error because there isn't a sleep between requests

[Plugin: Posterous Importer] 403 error because there isn't a sleep between requests

Viewing 15 replies - 1 through 15 (of 19 total)
  • please wordpress, honestly, this is embarrassing that this crucial plugin does not work :(((

    Create a temporary blog at wordpress.com, import your posterous blog there, export it again as a wordpress export file and import it into your new WP blog. Will work.

    Navjot, I’ve tried that. The Posterous Importer on WordPress.com works fantastically, but then trying to run the WordPress Importer on my standalone blog to import from wordpress.com keeps timing out because I have 245 posts each with at least one photo attachment. If I could just run the same Posterous Importer that runs on WordPress.com on my standalone site (i.e. if the plugin was FIXED by WordPress) then all would be resolved once and for all. At this rate I’m losing traffic and search engine credibility. It really is a shocking situation.

    245 posts is not that big amount that you should receive timeouts for the import. Tried checking for memory limit with your host? And if you are receiving timeouts for importing a WP.com blog, chances are you may get the same problem had the importer worked fine.

    Navjot, the size of the photos and videos attached to the posts is quite sizeable. And unfortunately I don’t see an error messages reported – so the timeout is not a confirmed timeout but just eventually nothing more happens and the screen says ‘done’ in the browser bar. Then I check … and sometimes it manages a few posts, other times not. The WordPress.com Posterous Importer worked perfectly however.

    Even worse, WordPress doesn’t import videos from Posterous and instead displays a link saying ‘watch this on Posterous’. Man, what a really crap experience this is.

    I’ve now upped the memory limit to 256MB in both php.ini and wp-config.php and Worpdress still stops importing around the point of 116 media items. These media items are seen under the media tab, but unattached to anything, and zero posts are imported. Does it really have to be THIS hard?

    Weird. Sorry can’t help much. You should post it at WordPress Importer’s Forum as its a WordPress importer issue now. Maybe someone will help you out there.

    I was able to import my posterous blog by adding a sleep command at the process_posts function of the importer.

    Just add the pause at the beginning of the function like this.


    function process_posts($url) {
    sleep(5); <- Add this pause
    $data = $this->get_page( $url, $this->username, $this->password );
    .........

    This function is at line 164 of the posterous.php file.

    If you have multiple sites in posterous you might get the same 403 error on the get_sites function, so do the same there.

    Good luck

    By the way.. I’ve got errors on the attachments. Posterous URL’s for attachments seem to be redirects to amazon s3 locations, and the posterous importer will return errors on those.

    These attachments won’t be copied to your blog, but linked instead.

    If you get any other 403 errors just hit refresh.

    Will see if I have time to work on the importer. I’ts kinda bad that this works on the paid platform and takes soooo long to be replicated to the open source project.

    A new version of the importer has just landed that resolves some of these issues. There’s a sleep now, for one thing, and there’s better handling of some types of media (audio/video) that wasn’t previously imported.

    hi guys

    i installed the latest .1 version of the posterous importer and still for 403 errors on getsites

    does anyone know if this is a plugin or posterous error

    to workaround i just manually inserted by posterous site id into the code -refer below

    function get_sites() {
                $this->site_id = 'MY_SITE_ID';
            }

    cheers

    justin

    It’s possible that you could resolve this by increasing the value in the usleep command to something > 1 second. Right now, it’s one and one one-millionth of a second, and maybe that’s not quite long enough to keep the Posterous api from throttling. I’d be curious to learn whether bumping the initial digit on that value to 2 fixes the issue for you. If your workaround does the trick, that’s fine too.

    thanks for the reply

    changing all usleep to usleep( 2100000 ); did not fix the problem

    question: how come your using version 1 of the posterous API instead of the new v2 – which can pull alot more info out

    note: with some non-wp php using v2 api(inc api token) i can getsites all fine

    cheers

    justin

    We’re using v1 of the API because that’s what was used in the original plugin and we wanted to iterate quickly on that to land some fixes rather than reimplementing using the v2 API. Patches welcome. 🙂

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Posterous Importer] 403 error because there isn't a sleep between requests’ is closed to new replies.
Skip to toolbar