Support » Plugin: Post Thumbnail Editor » [Plugin: Post Thumbnail Editor] No image on the left to crop

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author sewpafly

    (@sewpafly)

    I’ve seen a similar problem where the root issue appears to be related to wordpress somehow…

    To test if this is the issue, try to edit the thumbnail using the wordpress tools. (Go to the image and click “edit photo”). That should bring up a similar cropping interface as PTE (I imitate the wordpress code). If the picture doesn’t appear, it’s a wordpress problem.

    In that case try uploading a new image and seeing if it works.

    When I click on “edit image”, there is an image there for me to edit. Here’s a screenshot:
    http://gbd.alchemycs.com/wp-content/uploads/2011/11/thumbnail-problem2.jpg

    So it looks like it’s not a WordPress problem… Any other suggestions?

    Thanks!

    Plugin Author sewpafly

    (@sewpafly)

    Thanks for the screenshot. It actually proves it’s a wordpress issue though because the picture should appear larger on the left hand side just above the cancel and save buttons. It’s missing :(.

    Oh, I see….

    So, do you know of anything I can do about it? I guess I can try reinstalling WordPress and see if that does any good…

    Plugin Author sewpafly

    (@sewpafly)

    I wouldn’t uninstall wordpress. First try uploading another picture. The problems that I have seen like this appear to work after uploading a new picture… But your mileage may vary.

    Nope, I have uploaded dozens of pictures since I first noticed this problem, and it hasn’t worked on any of them.

    Plugin Author sewpafly

    (@sewpafly)

    How are you uploading the files? Is it through a method other than the wordpress upload code? Can you check the file permissions for the uploaded files?

    It would be nice to find the reason for the problem and submit a fix back to wordpress if we can find it.

    I’m using the normal WordPress uploader, and it’s putting them in the normal upload folder. The permissions are 0664, just like on other sites where this works.

    For what it’s worth, this is a theme that I wrote myself from scratch, back when I was first learning to write themes (now, instead of starting from scratch, I start with something minimal like Starkers). This seems unlikely, but is it possible there’s something missing in my theme that would make a difference?

    If you want, I’ll be happy to give you a login for the website – email me at [email address removed] and I’ll set that up.

    Any more ideas on how I might fix this? I’m hoping to get this website wrapped up in the next few days…. Thanks, sewpafly!

    Plugin Author sewpafly

    (@sewpafly)

    Can you reset the image in wordpress? To do this I go into the edit image settings and run some transformation on it (rotating it 90 degrees either way works). Then after you save it, you have the option of resetting the image. Does that work?

    There’s definitely something funky going on with images on this website. When I try to rotate an image, it just hangs – the little swirly circle tells me it’s trying to do stuff, but it’s been swirling for several minutes and nothing has happened. So it’s possible that there’s just something f’ed on my site and there’s not really anything we can do about…. But if you have any other suggestions, I’d be happy to give them a try!

    Plugin Author sewpafly

    (@sewpafly)

    I would try filing a bug: http://codex.wordpress.org/Reporting_Bugs

    I’d be interested with what the outcome would be…

    Well, it turns out that if I switch to a different theme, your plugin works just fine. So there’s something funky in my theme.

    It’s not a huge deal at this point – I’m going to end up having to do a bunch of manual image resizing even if I do get your plugin working. But I thought you’d want to know that it’s a theme problem.

    I have no idea what the problem in the theme could be, but like I said, it’s the first theme I ever wrote and I wrote it from scratch, so I’m not surprised there are some wonky things in it. I can send you the theme if you’re interested, but I don’t think it’s worth spending any more time trying to get it to work.

    Thanks for all your help!

    Plugin Author sewpafly

    (@sewpafly)

    Thanks for letting me know! I’ll try some other themes to see if I can duplicate the problem.

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Plugin: Post Thumbnail Editor] No image on the left to crop’ is closed to new replies.