WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Post Thumbnail Editor] Fatal Error on PTE 1.0.1

[Resolved] [Plugin: Post Thumbnail Editor] Fatal Error on PTE 1.0.1

  • MacItaly
    Participant

    @macitaly

    Hi Sewpafly,
    I just tried to upgrade from 1.0 to 1.0.1 but clicking on “Thumbnail” the modal windows shown only this message, instead thumbnail

    Fatal error: Class ‘PteLogger’ not found in /xxx/xxx/xxx/xxx/xxx/xxx/xxx/wp-content/plugins/post-thumbnail-editor/post-thumbnail-editor.php on line 132

    I tried changing theme and deactivating all plugins
    Any idea?
    Thanks in advance

    http://wordpress.org/extend/plugins/post-thumbnail-editor/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author sewpafly
    Member

    @sewpafly

    Thanks for the heads up, I had a problem with SVN… I just pushed out 1.0.2

    MacItaly
    Participant

    @macitaly

    Thanks Sewpafly,
    this works perfectly and solve also the problem with AdRotate.
    Well done! 🙂

    Thanks a lot, I’ll send you the italian translation asap

    vincentchuang
    Member

    @vincentchuang

    I have the same problem, I use xampp under windows system.
    post-thumbnail-editor version is 1.0.3

    Fatal error: Class ‘PteLogger’ not found in D:\xampp\XXXX\wp-content\plugins\post-thumbnail-editor\post-thumbnail-editor.php on line 132

    Could you help? Thanks

    Plugin Author sewpafly
    Member

    @sewpafly

    Completely uninstall and reinstall. This problem should not be there in 1.0.3. Also you can check that you have the file php/log.php.

    Functions.php should include log.php: http://plugins.trac.wordpress.org/browser/post-thumbnail-editor/trunk/php/functions.php#L6
    And line 131 should include functions.php.

    vincentchuang
    Member

    @vincentchuang

    Hi, sewpafly:

    Yes, you are right.
    After I check the functions.php, this program already include the log.php.
    I guess it’s path problem, then I follow your post-thumbnail-editor.php define for include functions.php file.

    I modify functions.php

    from

    require_once('log.php');

    to

    define( 'PTE_PLUGINPATH', dirname(__FILE__) . "/");
    require_once(PTE_PLUGINPATH . 'php/log.php');

    Then works fine.

    Thank you very much.

    Plugin Author sewpafly
    Member

    @sewpafly

    Thanks for the patch, I’ll add that now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: Post Thumbnail Editor] Fatal Error on PTE 1.0.1’ is closed to new replies.