WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Post Thumbnail Editor] Create Thumbnails button is disabled

[Resolved] [Plugin: Post Thumbnail Editor] Create Thumbnails button is disabled

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author sewpafly

    @sewpafly

    I haven’t been able to duplicate this behavior, I probably need some more information, but I can’t seem to think what it might be. Have you only ran this using Chrome? Can you try another browser?

    Same result in Firefox. That debug log: http://dpastey.appspot.com//aGXC/
    Same result in IE9.

    Ran the QUnit test. One failure:

    Submit button should be enabled
    Source:
    ()@http://[domain name]/wp-content/plugins/post-thumbnail-editor/js/stage2.js:25

    Let me know if you have any other ideas of things to try!

    Plugin Author sewpafly

    @sewpafly

    One other thing that I would like to see, can you pastebin the HTML for the page itself? From the Media Library open PTE in a new tab/window and then grab the HTML via a view source or some such command.

    Thanks.

    Fresh PTE page: http://pastebin.com/eFeQLZjh
    PTE page with all images checked: http://pastebin.com/CWzN4fHT

    It seems that the input boxes are not being marked as checked?

    Plugin Author sewpafly

    @sewpafly

    You might not have any other plugins installed, but it looks like maybe your theme is conflicting… There is a ton of javascript (that shouldn’t be there).

    <script type='text/javascript' src='http://emilymohnkern.com/wp-includes/js/hoverIntent.js?ver=20090102'></script>
    <script type='text/javascript' src='http://emilymohnkern.com/wp-content/themes/wpfolio/js/superfish.js?ver=3.3.1'></script>
    <script type='text/javascript' src='http://emilymohnkern.com/wp-content/themes/wpfolio/js/supersubs.js?ver=3.3.1'></script>
    <script type='text/javascript' src='http://emilymohnkern.com/wp-content/themes/wpfolio/js/wpfolio.js?ver=3.3.1'></script>

    Is there anything special with the wpfolio theme that you have configured? I could look to see if I could find a workaround, it should be a simple check to see if the DOING_AJAX flag is set.

    You’re right, it’s calling all its javascript in the header. Hrmmmm.

    Nothing special configured. No widgets, no menus. Using a child theme to tweak font styling and display-none an element.

    Chose this theme for a client to try and save time, rather than writing my own. Ha ha ha.

    Plugin Author sewpafly

    @sewpafly

    I couldn’t duplicate this with the wpfolio theme. Are you sure that you selected a size to modify AND you created a selection on the left hand side? (The button will not enable until this happens).

    Are you comfortable with downloading and using the latest version of github? (zipfile here)

    If neither of those things work you can try to comment out where the javascript is being enabled in wpfolio (functions.php lines 138-142). IF that works, a more permananent solution might be:

    if (!defined('DOING_AJAX')){
       wp_enqueue_script('hoverIntent', get_template_directory_uri().'/js/hoverIntent.js',array('jquery'));
       wp_enqueue_script('superfish', get_template_directory_uri().'/js/superfish.js',array('hoverIntent'));
       wp_enqueue_script('supersubs', get_template_directory_uri().'/js/supersubs.js',array('superfish'));
       wp_enqueue_script('wpfolio', get_template_directory_uri().'/js/wpfolio.js',array('supersubs'));
    }

    It conflicts with the following plugin: http://wordpress.org/extend/plugins/simple-image-sizes/ – I’ve disabled it and now it works like a charm

    I’m running Jigoshop, with the Stitched theme, and trying to edit some of the images generated automatically by Jigoshop.

    All of the images appear properly in the side menu of the PTE popup screen, but when I check off any of them, the General Thumbnails button does not become active.

    I turned on the PTE Debug and got this:

    http://dpastey.appspot.com//ZUe8/

    Plugin Author sewpafly

    @sewpafly

    @bravenewniche – you also have to select a crop region for the generate thumbnails button to become active.

    Ahhhhh!

    Works like a charm – thanks so much sewpafly!

    (A quick line of instructions for that would help folks like me 😉
    the crop editor button in the WordPress image editor also doesn’t light until you choose a cropping area, but in that case you only have a single image, and I think it’s the choosing of one or more images on the right hand side of your interface that made me think there was another step before I chose the area to be cropped)

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] [Plugin: Post Thumbnail Editor] Create Thumbnails button is disabled’ is closed to new replies.