WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Post Thumbnail Editor] Can't get plugin to work

[Resolved] [Plugin: Post Thumbnail Editor] Can't get plugin to work

  • Hi,

    I’m not sure if this has anything to do with me being on WordPress 3.3 or not, but I don’t seem to be able to use the plugin.

    Once I click on the “thumbnails” link under an image, I get the Thickbox window popup, where I can see in the background the image and all the image sizes under it. But this window remains greyed-out, with that animated loading bar running over it – and that’s how it stays forever. I close the window, try again, same thing. I just can’t get the loading bar to disappear and allow me to actually access the editor’s steps.

    Any feedback, suggestions, help would be hugely grateful – as this plugin is EXACTLY what I’ve been searching for!

    Many thanks,

    Biranit

    http://wordpress.org/extend/plugins/post-thumbnail-editor/

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author sewpafly

    @sewpafly

    Can you enable debugging (Settings -> Post Thumbnail Editor) and then after you click thumbnails there should be a tab that says debug on the window (you can click this to get a log of the current session).

    Also, what browser are you using?

    Hi sewpafly,

    I enabled debuggin, but clicking on the red “Debug” tab does nothing other than to reload that thickbox in the same “loading” state. It doesn’t display any log or anything.

    I’m on Firefox 8.0.1. I just tried it on Chrome (latest version) and got the same result.

    Thanks,

    Bira

    Just for the records, i’m having the very same issue as described by Biranit, with the same browsers. Worpdress 3.4.1.

    So close…

    Plugin Author sewpafly

    @sewpafly

    ildario, what does your debug output say?

    Hey swepaffy, as i said it, the problem is exactly the same as describe by Biranit. So, “clicking on the red “Debug” tab does nothing other than to reload that thickbox in the same “loading” state. It doesn’t display any log or anything.”

    Extra information, i’m using the plugin with backstreet theme: http://themeforest.net/item/backstreet-blog-magazine-theme/1680564

    Plugin Author sewpafly

    @sewpafly

    I don’t know if it’s possible, but you probably have a conflict with another plugin. If you have a test installation maybe you could try disabling all other plugins and then re-enabling one at a time. Known conflicts occur with WPML and contact forms (these plugins inject javascript on every page — which breaks PTE). If you can tell me which plugin is causing the problem I’ll look for a quick workaround for you.

    Hey sewpafly,

    I am hoping to help you while you also help me. I have the thumbnail editor on a handful of my sites, but I just installed this on 4 new sites and am getting the same issue on all of them. These 4 new sites are on a separate server then my other sites, but are all on the same server. I have deactivated all plugins and it didn’t help.

    All sites are running 3.4.1, along with Genesis framework. The debug button is also not working for me as its the exact same issue as above. Any help would be greatly appreciated, and any questions you have to help debug the issue I will be available to answer.

    Plugin Author sewpafly

    @sewpafly

    @kzipp – How comfortable are you firing up Google Chrome and checking out the javascript console? (Or you could use firefox/firebug).

    I’m not familiar with the genesis framework, but I assume that this framework is injecting javascript on this page that causes an error and stops the rest of the javascript from loading and running. In this case we just have to track down where the Genesis stuff injects the javascript and tell it to not do that for AJAX pages. (See this post for the particulars for a different plugin… https://github.com/sewpafly/post-thumbnail-editor/issues/38#issuecomment-3558922)

    I should roll out a change for this because it is by far the biggest problem people have with this plugin. I just need to find the time…

    Plugin Author sewpafly

    @sewpafly

    Can you provide more information about the framework you are using, including the URL to download it?

    It is also known as Sutdiopress. I am actually running Genesis on another site as well along with your plugin and have no issues. The site with the issue is actually running wordpress multisite. That is the only issue I can see different between the site with the issue, and other sites of mine that work perfectly, but I don’t see how that would cause the issue.

    Plugin Author sewpafly

    @sewpafly

    I made some notes below, but before I get too far, try this first:
    1. Go to your media library
    2. Find the picture you want to edit
    3. Right-click on the “Thumbnails” option and choose, “Open in new tab”
    4. Do you still have the same problem?

    The problem appears to be occuring because something is trying to load wp-lists.js (which doesn’t happen on my installs). I imagine that since all your other plugins are disabled then it is either the theme you are using or the genesis framework.

    (Perhaps it is an option that could be different between the sites where PTE is working and the ones where it isn’t?)

    I am still having the same problem in a new tab.

    I appreciate the time you are putting into getting this resolved, and I will continue to do the same and see what I may be able to find to help prevent this issue in the future.

    Plugin Author sewpafly

    @sewpafly

    In your new tab, can you “View Source” and find where the wp-lists.js call is? Copy that and any other <script> lines to a pastebin for me. Thanks.

    Sorry for the delay.

    http://pastebin.com/PbC5efuk is the entire page. I do see wp-lists.js, but I don’t think this is much of a help.

    2 Notes.
    The gap at the top is true, not a copy and paste issue, it looks like that when I view source.
    I replaced my domain with domainname.com

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Resolved] [Plugin: Post Thumbnail Editor] Can't get plugin to work’ is closed to new replies.