Support » Plugins and Hacks » [Plugin: Post Templates] Plugin not working anymore – discontinued?

  • Authors homepage returns not found.
    Is this plugin dead? Sad if it is, sounded very promising and honestly; this feature should be with wordpress by default.

    In any case, after installation on latest WordPress version (2.8.1), I try either “Create post template” or “Create page template”, both return:
    “You do not have sufficient permissions to access this page.”

    I’m admin, btw.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m having same problem, sux.

    same here.
    a working solution anyone ?
    thnx

    I haven’t seen any response to my questions here, so I’ve switched to Article Templates.

    The author seems to be having trouble with the database of his site.
    The permissions problem also occurs with the Duplicate Post plugin with WP 2.8.1. I guess, maybe WordPress develpment is going to fast, no?

    Article templates works great, thanks for the suggestion!

    It seems that global.css changed and messed up the editors at least in 2.8 that I’m using.

    1) edit-post-template line 114 <div id="side-info-column" class="inner-sidebar" style="display:block">
    2) edit-post-template lines 171&172 <div id="post-body" class="has-right-sidebar">
    											<div id="post-body-content" class="has-right-sidebar">
    
    4) edit-page-template line 112	<div id="side-info-column" class="inner-sidebar" style="display:block">
    3) edit-page-template lines 156&157<div id="post-body" class="has-right-sidebar">
    			                         <div id="post-body-content" class="has-right-sidebar">

    There is a patch that fixes the bugs in Post Templates plugin.

    Alternatively, you can download the patched version of Post Templates.

    Hope that helps.

    Best regards,
    Vladimir

    Version 3.4.0 is now compatible with WP 2.8+
    Sorry for the delay for the update.

    Vincent (the plugin author)

    Vincent,

    Your permission error fix is partially correct. In fact, you should not have added these lines:

    $_registered_pages[get_plugin_page_hookname('post-template/includes/plugin-class.php','')] = true;
    $_registered_pages[get_plugin_page_hookname('post-template/includes/post-templates-dao-class.php','')] = true;
    $_registered_pages[get_plugin_page_hookname('post-template/includes/post-templates-shortcodes-class.php','')] = true;
    $_registered_pages[get_plugin_page_hookname('post-template/includes/managepages/managepages.php','')] = true;
    $_registered_pages[get_plugin_page_hookname('post-template/includes/managepages/JSON.php','')] = true;

    You should put to $_registered_pages only those pages that will be shown to the user (this is what CORE-2009-0515 vulnerability is about).

    Hope that helps.

    Best regards,
    Vladimir

    Jeff Chandler

    (@jeffr0)

    Volunteer Moderator and Voice of WP

    I’m using version 3.4.0 and I’m still receiving the “You do not have sufficient permissions to access this page.” error. I’m using WordPress 2.8.4

    Jeff Chandler

    (@jeffr0)

    Volunteer Moderator and Voice of WP

    I wanted to add that the patched version you linked to works correctly, however it notifies me that there is an upgrade available for the plugin which it says 3.4.0. When I upgrade, I’m back to receiving the same error.

    Hi Jeffr0,

    Just replace

    Version: 3.3.0

    with

    Version: 3.4.0

    in post-template/post-template.php and it won’t complain anymore 🙂
    My patched version has the same functionality as 3.4.0.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Post Templates] Plugin not working anymore – discontinued?’ is closed to new replies.