WordPress.org

Support

Support » Plugins and Hacks » Portable phpMyAdmin » [Resolved] [Plugin: Portable phpMyAdmin] WP_HOST Error

[Resolved] [Plugin: Portable phpMyAdmin] WP_HOST Error

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Ciprian

    @butterflymedia

    Updated to version 1.2.9.4. Removed all deprecated errors and removed the WP_HOST error. Still in Beta, still looking for feedback.

    Ciprian, I am delighted to see that after a good 10 months when you said “I will change that in a blink” that you have at last updated this wonderful plugin.

    Only a couple of days ago I had replaced all the deprecated statements myself in my version.

    My server does not use local host and the link to…
    /wp-content/plugins/portable-phpmyadmin/wp-pma/scripts/setup.php does not work as No file exists.

    You also reference the old config file in your help section.

    What is the config file now called so I can get your plugin working on my sites?

    If you can grab all the other info from wp-config, I do not truly understand why you do not grab the DB-Host as well.

    Anyway, I hope you have not been unwell! It’s great to see you’re back.

    Richard Young

    Plugin Author Ciprian

    @butterflymedia

    Hey thanks. This recent update messed with something.

    The config file is the same, however it wasn’t there in version 1.2.9.4c. Tried with a “d” version, and right now I’m working on it.

    RE: v1.2.9.4e

    Just updated an whilst the PPMA page shows the correct IP for my DB_Host the main part (central) is blank.

    I tired to edit config.php and notice that you are now using…
    $cfg[‘Servers’][$i][‘host’] = DB_HOST;

    I changed it to my IP and then a wrong IP and PPMA still showed the correct DB_Host. This tells me that you are not actually using the config.php file !!!

    ALSO…

    You need to edit your plugin’s HELP page as it still says…
    Help

    If phpMyAdmin is unable to connect to your database, it means your host is different than localhost, the default name assumed by this plugin. Please edit wp-content\plugins\portable-phpmyadmin\wp-pma\config.php and add your host at line 51, $cfg[‘Servers’][$i][‘host’] = WP_HOST;.

    This is the wrong line as you use DB_HOST now and it has changed to LINE 32 (not 51)

    Hope this Helps !!!

    RE v1.2.94e

    Image of PPMA page HERE

    Getting the same screen as Cate even after adding the host to the config – which we didn’t have to before, being way better back then.

    View post on imgur.com

    Plugin Author Ciprian

    @butterflymedia

    I know about these errors and I’m working on them. I am in fact using the config.php file, but somehow the information does not get passed to PPMA.

    Plugin Author Ciprian

    @butterflymedia

    Version 1.2.9.5 fixes most of the errors. Please confirm!

    Working for me now. Had to disable Redirection Plugin and then re-activate, now it is working for me! Thanks a lot Ciprian, awesome support!

    By the way, I didn’t change anything in the configuration, just updated, turned it on and worked!

    RE: 1.2.9.5

    I had to deactivate all my plugins and activate PPMA on its own, before anything new happened. Once ‘working’ I reactivated all the old plugins and it carried on ‘working’. Before that I tried to just deactivate and reactivate PPMA with the other plugins but it did nothing and still got a blank central section.

    I say ‘working’, because it’s not. I get a load of deprecation warnings…

    Deprecated: Function ereg() is deprecated in /var/sites/p/mydomain.com/public_html/wp-content/plugins/portable-phpmyadmin/wp-pma-mod/libraries/check_user_privileges.lib.php on line 59

    Deprecated: Function ereg() is deprecated in /var/sites/p/mydomain.com/public_html/wp-content/plugins/portable-phpmyadmin/wp-pma-mod/libraries/check_user_privileges.lib.php on line 60

    Deprecated: Function ereg_replace() is deprecated in /var/sites/p/mydomain.com/public_html/wp-content/plugins/portable-phpmyadmin/wp-pma-mod/libraries/check_user_privileges.lib.php on line 65

    Deprecated: Function ereg_replace() is deprecated in /var/sites/p/mydomain.com/public_html/wp-content/plugins/portable-phpmyadmin/wp-pma-mod/libraries/check_user_privileges.lib.php on line 65

    Deprecated: Function ereg_replace() is deprecated in /var/sites/p/mydomain.com/public_html/wp-content/plugins/portable-phpmyadmin/wp-pma-mod/libraries/check_user_privileges.lib.php on line 66

    Regards.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] [Plugin: Portable phpMyAdmin] WP_HOST Error’ is closed to new replies.
Skip to toolbar