Support » Plugin: Portable phpMyAdmin » [Plugin: Portable phpMyAdmin] Worked the first time then it does not…

Viewing 8 replies - 1 through 8 (of 8 total)
  • I am having the same issue. This plugin has not worked since day one, and I always get the error “Error: #2005 – Unknown MySQL server host ‘WP_HOST’ (1)” even though it displays the correct server name elsewhere on the screen.

    Also experiencing this error although right from the beginning. Looking for guidance…

    Issue resolved, for me at least, by removing the following block from .htaccess which had been introduced to clean up URLs. This same block was preventing Adminer and BackWPUp from working.

    #Redirect parameter filled URLs to clean ones
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{QUERY_STRING} .
    RewriteCond %{QUERY_STRING} !^(s|p)=.*
    RewriteCond %{REQUEST_URI} !.*wp-admin.*
    RewriteRule ^(.*)$ /$1? [R=301,L]
    </IfModule>
    Plugin Author Ciprian

    (@butterflymedia)

    Hey, thanks for your feedback. It seems that no redirection should exist for wp-admin, such as the plugin Login Stealth is doing. I’ll check that.

    I’m having the same error. I don’t have time to really investigate the problem…..it used to work fine.

    #2005 – Unknown MySQL server host ‘WP_HOST’ (1)

    Seems to be a potential fix here:

    But again I don’t have time to tinker and debug this.

    Any chances of an update coming? Love this plugin…!!!!

    Plugin Author Ciprian

    (@butterflymedia)

    An update is coming soon. Thanks for the heads up with the fix. It should fix problems with ‘localhost’ users. What about the others? I’ll have to read the WP_HOST documentation more thoroughly.

    Hello,

    I am not having trouble on my localhost install.

    It’s broken on my dreamhost install. I tried changing WP_HOST to the actual mysql hostname but it only threw different errors.

    I have used this plugin without any problems for quite a while. Ciprian I hope you can fix it, it’s quite useful and I appreciate you making it available.

    Barry

    I am still having the error message “#2005 – Unknown MySQL server host ‘WP_HOST’ (1) ” , although I did change WP_HOST to localhost. What could it be ?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Portable phpMyAdmin] Worked the first time then it does not…’ is closed to new replies.