WordPress.org

Forums

Polylang
Homepages keeps redirecting to default (4 posts)

  1. jasionn
    Member
    Posted 2 years ago #

    Hi guys,

    i've experienced problem using polylang on my wordpress - I've default lang set to en, and I also have three other languages. I've latest posts from specific category listed on my homepage (query_posts($query_string . '&cat='.pll_get_term(5).'&posts_per_page=4');) and I can't get my other language homepages working - it keeps me redirecting (301) from other language homepage to default one (mydomain.com/de -- 301 --> mydomain.com)
    which of course is in default lang.
    What I want to do is to have all four homepages under:
    mydomain.com - default - en
    mydomian.com/de
    mydomain.com/it
    mydomain.com/ru
    displaying posts from translated categories.

    My settings:
    - permalink structure: /%postname%/
    - language codde added to all urls
    - unchecked when accessing homepage, set the lang...
    - no /language/ in permalinks
    - hide language info for the default one
    - allow to synchronize categories....

    I'd really appriciate your help - got stuck for couple of hours :( on something which I hope will show up quite simple to solve...

    http://wordpress.org/extend/plugins/polylang/

  2. hmigneron
    Member
    Posted 2 years ago #

    Did you ever figure it out? I am running into the exact same problem with very similar settings.
    I tried with most combinations of settings on the language settings page and nothing works.

    I have a few sites on which I run polylang without this problem (and they have very similar settings too!)

  3. jasionn
    Member
    Posted 2 years ago #

    yes I did, but how...I can hardly remember :( As far as I remember, I changed reading settings - homepage shows static page and created static page with no content + three translations of this page. Now when I choose one of them as a static page in reading settings, everything works well.

    Anyway, I couldn't make it work, when I had latest posts checked in the reading settings.

    Hope it's gonna work for you :)

  4. hmigneron
    Member
    Posted 2 years ago #

    Thanks for your reply.

    I ended up backing up my database and recreating my home page from that. For some reason it worked fine after I deleted and re-created the page (my settings in reading were already OK so no idea what was causing it)

    I am thinking that maybe I restored from the backup before I installed polylang the first time and maybe that's what caused the problem? In any case, everything is fixed now.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Polylang
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic