WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
default language doesn't work (10 posts)

  1. The Crazy Travel
    Member
    Posted 3 years ago #

    If you choose one language as default and ask the plugin not to display the language url for that one, when you try to go with the plugin widget doesn't work.

    I fixed it putting my own widget for relinking to the different language urls; but now my second thought is that, when someone get directly connected to some foreign language, he will not be able to change to the default, because if he follows the link of the default language (without /language), he will go to his language (or the one that is set in his computer).

    Any solution? Thanks!

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 3 years ago #

    Could you please send a link so that I see what happens ?

  3. The Crazy Travel
    Member
    Posted 3 years ago #

    Here is my website: http://miesquinica.com/

    I disabled the widget and put my own links now, but as the domain should change depending on the configuration of the browser of the visitor... could happens that the spanish link (the default one) doesn't work if they have the english or latvian browser.

  4. Chouby
    Member
    Plugin Author

    Posted 3 years ago #

    When I go to your home page, I get the default one in Spanish (my browser preferences are set to French 1st and English as 2nd). Did you check the option "When the front page is visited, set the language according to the browser preference" ?

    If I then read a post in Spanish and want to get its translation in English (which exists), I am sent to the homepage in English. Is that the result you expect ?

    Could you precise what did not work with supplied widget ?

  5. The Crazy Travel
    Member
    Posted 3 years ago #

    I have able again the widget for you to see it and check it. Thanks!

    If you are in English and you change to Spanish it goes to 404.

  6. The Crazy Travel
    Member
    Posted 3 years ago #

    The widget change me too to the main page of the language, not to the linked article.

    And yes, it's checked the "set the language according to the browser preference" option.

  7. Chouby
    Member
    Plugin Author

    Posted 3 years ago #

    OK I see. You checked "Display as dropdown" in the widget options. In this case :
    * it is normal that it sends you to the homepage and not to the translated page. I did not implement the feature yet (and probably won't in the near future). If you want to link to the translated page, you have to uncheck this option.

    * It is not normal that it sends you a 404 error for the default language. So here is a new bug. I will try to correct it in the v0.4.3 that I plan to release today or tomorrow.

  8. The Crazy Travel
    Member
    Posted 3 years ago #

    Oh! It was just that! Great :D

    By the way, how can I configure the flags? Can I upload the .png that I already prepared for my temporal solution and use it with the widget? Thanks again!

  9. Chouby
    Member
    Plugin Author

    Posted 3 years ago #

    Yes it should be possible by putting your flags in the local_flags directory. You will have to modify your css too as the outputed html is different from yours (I use html unordered list to display the languages).

    But do wait the v0.4.3 to do that as I know that your custom flags will be removed when upgrading (an other bug that should be removed in v0.4.3...)

  10. The Crazy Travel
    Member
    Posted 3 years ago #

    Ok, thanks Chouby. ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags