Support » Plugin: PollMe » [Plugin: PollMe] Plugin does not work

  • Resolved CarpetGuy

    (@carpetguy)


    I just installed and tried to activate, but, I got an error message.

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home1/opinion1/public_html/opinionhead/wp-content/plugins/pollme/library/base/b4v/Application.php on line 141

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author DCoda

    (@dcoda)

    I can’t get that error to occur on my system.
    However looking at the error message i’ve recoded the part it is referring to, to remove the need for the PAAMAYIM_NEKUDOTAYIM (::), but i have no way to test this.
    I’ve just uploaded version 1.0.1 which you should be able to find here in a few minutes or so in the Other Versions section.
    Please let me know if this resolve this, then I will mark it as the current version.

    Can I also ask, what version of PHP are you running, and on what OS and web server?
    Just so i can get a feel for the problem.

    Regards
    Damian.

    DCoda – I read previous message and then downloaded 1.0.1 with same error

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home2/xxxx/xxxx_html/xxxxx.com/wp-content/plugins/pollme/library/base/b4v/Application.php on line 141

    btw – here is my server info

    Apache version 2.2.17
    PHP version 5.2.14
    MySQL version 5.0.91-community
    Architecture i686
    Operating system linux

    Plugin Author DCoda

    (@dcoda)

    Thanks for the info.
    A new version is available that should fix the problem in the other versions area version 1.0.2.

    If you can let me know how this goes, and then I’ll make a full proper release of this version. The code will be release in the next 24 hours if No problems with it are posted, but a positive confirmation would speed up the release 🙂

    It seems that the offending code, may not have been PHP 5.2 compliant and it has been removed as even if it is not called it still seems to cause problems.

    Regards
    D

    Sorry to say – new error popped up

    Fatal error: Class ‘w4v_Controller_Action_AdminMenu’ not found in /home2/xxx/public_html/xxxx.com/wp-content/plugins/pollme/library/wordpress/Controllers/SandBoxSandBoxController.php on line 2

    Plugin Author DCoda

    (@dcoda)

    That files isn’t part of the 1.0.2 project. Can I take it you copied the 1.0.2 over the old installations?

    If you can you delete the folder and copy in the 1.0.2 project again. I’ll amend the instructions to make this clear, just to be safe.

    Thanks.

    I deleted the the entire directory via cpanel and reinstalled fresh 1.0.2 – can I just delete this file?

    Ah, never mind I deleted it on my server, but not in my download directory – let me try again

    Plugin Author DCoda

    (@dcoda)

    Deleting the file should work. BUt to be sure of the stability of the plugin a fresh install would be more sure.

    Thanks.
    -D

    Ok….Bingo!! Plugin loaded – have not set it up yet..but no errors on loading this time…..Thanks for all your help -looking forward to testing this out

    Plugin Author DCoda

    (@dcoda)

    Thanks for the help in getting it sorted. Like I said previously, it didn’t happen with my version of php so it would have been difficult for me to fix without help 🙂

    Just releasing version 1.0.3, as the current version with the instructions to disable and delete old versions before installing.

    Thanks again

    -D

    Just got my first poll going – way too easy – very nice layout – will download some of your other survey and quiz stuff later – have not found many that work well. And if they are anything like the Poll – it should be interesting

    Plugin Author DCoda

    (@dcoda)

    Glad to know you think it was easy. I often get so familiar with an interface I find it hard to tell.
    Will of coarse being looking into other Google charts to ad.

    Thread Starter CarpetGuy

    (@carpetguy)

    Hey DCoda, sorry, I started this and had to leave, I just got back and saw what has been done, great job, I really had not expected any response so soon, I am sure everyone thanks you for that.

    Anyway, I just installed 1.03 and it works just fine, nice job, and again, thanks for such a quick response!

    Plugin Author DCoda

    (@dcoda)

    Thanks for getting things started. I felt compelled to fix it quickly as I hate not to deliver 🙂
    Glad its working for you.
    -D

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: PollMe] Plugin does not work’ is closed to new replies.