Support » Plugins » [Plugin: Podpress] very slow publish post page load

  • Resolved Opally



    Symptom: extremely slow page load time for admin publish/edit post page, taking over 3 minutes, and stalling after the H4 Podcasting Files header. During the page load, it is impossible to save text or embed images and media.

    In case someone else has this problem, it seems to have been caused by PHP 4.x. The solution was to upgrade to PHP 5.x

    I’m now using 5.2.9 and the problem went away immediately.

    The information that PHP 5.x is required should be in the plugin details.

Viewing 5 replies - 1 through 5 (of 5 total)
  • What is your “Max Number of Media Files” value (general settings of podPress)? If you increase this value e.g. to 20-30 , it starts to slow the page load time for admin publish/edit post page measurable. Higher values will increase the page load time more. It can take minutes with high values. That depends mostly on the server and eventually on your computer, too.
    The default value is 10 but if you never have more than 1 or 2 media files per post than you could decrease the value.

    You have raised an interesting question: Is PHP 5 a requirement of podPress?

    There is the function memory_get_usage in the code but there is also a function_exists check. In 8.8.4 I used accidentally a PHP-5.2.3-parameter of htmlentities in the feed assembling functions of podPress but since 8.8.5 is a version check in place which prevents problems with older PHP versions.

    Today , I installed PHP 4.3.10 and MySql 4.1.10 as part of XAMPP 1.4.12 (for Linux), I installed also WP 3.0 and podPress
    This PHP and this MySQL version is nearly what the current minimum requirement for WP 3.0 is ( PHP 4.3 and MySQL 4.1.2).

    The result of that test is: that this combination worked fine. No long page load time on the editor page and no difference to other installations with PHP 5.2.9 or 5.3.1.
    Updating to PHP 5.2.9 has solved obviously the problem you have described but PHP 5 is not a requirement for the current podPress ( version.

    I’m also currently experiencing this problem exactly as Opally describes.

    I changed the “Max Number of Media Files” down to 1 and am able to wait a few minutes for the page to load. Then the podpress section appears. But thereafter, I am not able to edit/add any media.

    @davidpey: Is the Podango Integration activated? That would slow down page load of the editor page.
    It is okay to set “Max Number of Media Files” to 10 (the default value) but if set it e.g to 100 or a higher value, it would definitely slow down the post/page editor page.
    If you set this value to 1 then should be able to add exactly 1 media file with podPress to a post or page.
    That nothing happens when you click on the “Add media file” button could be a sign that there was a Javascript error during the page loading process. Can you confirm that? If there is a Javascript error then please, post the details. (The Firefox browser has something which is called error console. Open it delete the old message if there some and reload the editor page. (Other browsers have something similar.))

    Which podPress version do you use? Which WP version?


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Podpress] very slow publish post page load’ is closed to new replies.