Support » Plugin: podPress » [Plugin: podPress] Podpress Stats not showing up

  • Resolved miaontop


    I am running podPress on WordPress 2.7. I have validated my feed. However, my stats don’t show up for my latest podcast. The stats actually weren’t showing up before I updated to the latest podPress. I thought the update would help. But it hasn’t.

    Any advice would be greatly appreciated.

Viewing 15 replies - 16 through 30 (of 30 total)
  • My Media Files contain unique values. And when I re-posted Episode 25, I used the same media file, but changed the post name. I had been using an em dash in my titles. Then I was told this might be why the permalink to Episode 25 was funky. So when I re-posted I changed the em dash to a regular dash.

    In any event, neither posting show up in the stats.

    Another issue, I would like to mention because I am not sure if it is related. Is that Episode 25 and , now, Episode 26 are continuously posting in iTunes. A listener told me that Episode 25 was downloading a new copy per day. In my iTunes, I have 2 copies of both Ep. 25 and 26. The two copies are Ep. 25 are the em dash and regular dash ones. But Ep 26 is just 2 of the same.

    Any idea on this? I thought this might be related to the missing stats. But now that this is happening with Ep. 26 and the stats are showing up, I am not sure.

    Thanks so much for your help.

    Plugin Author ntm


    In any event, neither posting show up in the stats.

    Unfortunately, I have still no idea what the reason could be.

    I have subscribed some hours ago to your RSS2 feed and downloaded episode 26. Now, iTunes shows me the episode again as an not-downloaded, new episode and the episode I have downloaded. (I can experience problem, too.) I have also downloaded episode 25. But there is no new download for that episode in the list. I would explain the doubled download of this episode with the re-post and the changed post title. But I don’t know it for sure.

    I have looked again into the source code of your RSS2 feed and one difference between these two posts is that one has the line <guid isPermaLink="false"></guid> (the permalink to the post of episode 25) and the other one has the same line but only with a number instead of an URL <guid isPermaLink="false">1886983054</guid> and that number is changing over time. Maybe iTunes recognizes the change and takes it as a sign for new or changed episode.
    None of the other podcast posts (resp. items) has such a changing guid. But there exists at least one other post item which has also such a guid, the “Shedding Skins” post.
    In the RSS 2.0 specification, you can read this: “guid stands for globally unique identifier. It’s a string that uniquely identifies the item. When present, an aggregator may choose to use this string to determine if an item is new.” and maybe iTunes is using this string to determine if an item is new.

    These <guid> lines are produced by WP and not by podPress.

    Thank you so much for trouble shooting this issue.

    The re-downloading was happening for Episode 25 and I guess it got transferred to the latest Ep. Interesting that you found that the Permalink is not staying the same.

    I just updated to WP 3 in hopes that would change things. It has not.

    Looks like I will be moving on to the WP forum. I don’t know how this works. Is there someone you can pass me onto or do I start another post? Which BTW do you work for podPress or just a helpful person? Either way I appreciate your time.


    Plugin Author ntm


    I have took another look at the guid problem resp. functions which are producing this guid and I have discovered that it is possible that podPress could have set these numbers instead of a proper guid link.

    If podPress creates these strange guid numbers then it is in the line 555 of the file podpress.php (v8.8.5.3). You should change it from:

    $wpdb->query("UPDATE ".$wpdb->posts." SET guid = '".$guid."' WHERE ID=".$post->ID);


    $wpdb->query("UPDATE ".$wpdb->posts." SET guid = '".get_permalink( $post->ID )."' WHERE ID=".$post->ID);

    To correct e.g. the permalink of the post of the last podpcast episode you probably need to edit this value in the db. I have for my web site resp. the db a web-based db administration tool called phpMyAdmin. Do you that?

    The guid for a post should be where x is the ID number of that post (see the first column in the wp_posts table). For the post of episode 25 it is e.g.

    p.s.: I’m not one of the original authors of the plugin and I’m not an employee or associate of But I’m a volunteer who has written many patches for the last podPress versions, mainly to help my favourite podcasters – but not only them.


    OK. So I changed the line 555 item. Am I to understand that this will help the next most recent podcast from having this problem?

    Do I need to change my Permalink setting? It is still set to day and name.

    In terms of the second part of your last post, the phpMyAdmin fix. I do not have that tool. Also, a friend hosts my site, so I think I do not have access to the database. Should I get in touch with her to make this change? Or can you further direct me more on where to get the phpMyAdmin?

    I really appreciate your volunteer efforts. This has been a bit of a mind scramble for me.

    Plugin Author ntm


    So I changed the line 555 item.

    That is a good thing and the next podPress version will have this modification, too. This line is part of a function which creates a guid if a post has none. With this modification podPress will create these guids like WordPress. So, Yes, if podPress was the source of this wrong guids then this modification will fix this problem for future posts.

    But for the existing posts you (or your friend) should change the guid of the post of episode 26. This phpMyAdmin is also part of WP plugins. You could use e.g. or (PHP 5.2+ required).
    Before you try out one of these plugins make a backup of the db of your blog!
    Both plugins will add a new page to the Tools menu of WP. If you open it you will see on the left a list of all db tables of your blog. Click on “wp_posts” (If wp_ is not your db prefix then you could look into the wp-config.php file to find out the prefix) and open the db table of the posts which will appear on the right side of the page.
    If the table headers are now Field, Type, Collation, Attributes …. then click on the tab “Browse” above the table.
    You should see a table with headers like ID, post_author, post_date, post_date_gmt, post_content, etc.
    By clicking on the table headers you can sort the rows resp. posts. Order them by the ID column with descending IDs. The post of episode 26 is one of the latest posts and because of that it has one of the highest IDs.
    Be aware that this table contains besides the published posts and pages also e.g. revisions of the posts.
    Search for the right post title. The row with post_title = title of the post of episode 26 and post_type = post is the row of the actual post.
    If you have found it, click on the pencil symbol at the beginning of that row to edit the values of the post.
    Instead of the table a form with a lot of input fields should appear. Now, you can edit all the values of the post.
    Take the number of the ID field and build a new URL in the guid field with that pattern: . Use instead of the x the number from the ID field.
    Save the modification. Below the field is a “GO” button.
    It is enough to change only the row of the post and not the ones of the revisions as long as you do not decide to switch back to one of the revisions.

    That is it.

    But again: Make a backup of the db before you start to edit something!

    Do I need to change my Permalink setting?


    It is still set to day and name.

    That is okay.

    I looks like I can do this even though I don’t have access to my hosting info? Is that correct?

    Also, how do I know if I have PHP 5.2?

    I went ahead and downloaded the PHP My Admin plugin. But when I go to browse my posts from the table, I do not see my entire list. I see 2 welcome ones from WP. Is that because I don’t have access to my server.

    Also, I checked out my page source. And this is what read for Ep. 25. Looks better than number scramble before, but should it looks more link the others?

    <guid isPermaLink=”false”></guid&gt;

    Episode 25:
    <guid isPermaLink=”false”></guid&gt;

    Plugin Author ntm


    “2 welcome ones ” ? Do you mean that the dark grey and orange page section disappears and you see instead only the admin site header twice?
    Maybe try with a different browser e.g. FireFox or try out the other plugin. You could use the plugins WordPress System Health or WP-Memory-Usage to find out the PHP version.

    If you click on “wp_posts” and “Browse” you should see a table with column headers like ID, post_author, post_date, post_date_gmt, post_content, etc.
    Both plugins are taking the username and the password for the db from the wp-config.php file and that you have seen the list of the db tables of your blog is a clear sign that this part of the plugin is working and that you have access to the db.

    I checked the source code of your RSS feed again, too and you are right. The guid of the post of episode 26 looks now like the URL to this post with your current permalink setting and that is totally ok. URLs with the other schema are also good because they are working always – independently of the current permalink setting.
    The only guid which has still such unusual guid value is the “Shedding Skins” post. Changing its guid is probably not relevant for iTunes but you could try to open the post in editor and to save the post again.
    Maybe this guid will be corrected automatically.
    Have you done this with the post of episode 26 since the adjustment in the podpress.php file?

    I don’t have a dark grey and orange page section.

    When I am in the Browse section of Posts, I see two posts:
    1. This is an example of a WP page
    2. Welcome to WP. This is your first post.

    I downloaded the other plugin, PortablePMA. This one asks for a user name and password with the user name filled out with the name of my friend who hosts my site.

    This makes me think I do not have access and need her to do this.

    So even tho Ep. 26 does not have the same exact link as Ep. 25, do you think it is fixed?

    Re: Shedding Skins post
    Open in editor? What do you mean? Should I delete the post and re-post. Or what exactly am I supposed to do in editor?

    I have not changed Ep. 26 since the adjustment to the podpress.php file.

    Thanks, again.

    Plugin Author ntm


    It seems, that the wp-config.php file of your blog does not contains the db password. Maybe the password is defined somewhere else. That the PortablePMA plugin asks for the password means that the plugin cannot retrieve it automatically from the wp-config.php file. So, I guess that you need to ask your friend.
    You could also look into this file yourself. Usually it looks like in this example:
    If you install a WP blog this file is created automatically and filled with the data you would insert during the installation process.
    But if your friend has installed the blog in a none-default way then you should ask her.

    I have made a screenshot which shows what the phpmyadmin plugin (PortablePMA) page should look like:

    So even tho Ep. 26 does not have the same exact link as Ep. 25, do you think it is fixed?

    Yes, I think so.

    Since you have not changed the link yourself manually via the phpMyAdmin interface, it looks like a function which will be executed at some point in the WP Site Admin section has corrected it. Maybe it was the line you have modified in the podpress.php file. It is really hard to say because the internal procedures of WP are very complex. But the guid URL of the post of episode 26 has now the same structure as the other URLs on your blog site and the modified part of line 555 get_permalink( $post->ID ) creates with a given ID an URL with the current permalink structure. I think it is possible that the modified line is maybe responsible for the corrected URL and if you do that again what you have done with the post of episode 26 since the modification then it could correct also the guid of the Shedding Skins post.
    But the question is probably what you have done.
    I thought maybe you have modified the post of ep. 26 in post editor (I mean this page where you write and edit your posts) or at least clicked Update. In general, when you click on Publish or Update a lot of things happen internally in WP e.g. the post content can be filtered by a plugin or WP before it goes into the db.
    That is why I hope that it will help if you would go to Site Admin > Posts > Posts and open the Shedding Skins post by clicking on Edit below the post title (see this screenshot).
    Open it and click on Update. Don’t change a thing. Hopefully that is all you need to do to correct the guid of the Shedding Skins post.

    Sorry for my bad English! I hope that I could clarify my last post.

    Plugin Author ntm


    The next podPress version will be released a few days. One modifications will be a modified Quick Counts table (stat logging: Counts Only). The Post and Publication Date column will be removed and the table will show only the downloads per media file. This modification of the appearance will not alter the related db table or effect other parts of the plugin. So, you can try it separatly and before the release of the new podPress version. You can download this modified file here:
    Make a copy of the “old” podpress_admin_stats_class.php file and replace /wp-content/plugins/podpress/podpress_admin_stats_class.php file with the new one.
    The ep. 25 should be visible ín the statistic table. Please, tell if it is still not visible in the modified table (check out all table pages).

    Hello –

    I downloaded the new podPress as you suggested. And Ep. 25 stats show up! Hooray!

    The only thing I don’t love about this new podPress is that the stats are based on the media file and in alphabetical order. I preferred it listed by release date. But I will take what I can get.

    Thanks for your more detailed instructions on how to fix the Shedding Skins post. My friend who hosts my site is on vacation. So I have to wait for her return to look into this (I think next week).

    I did open the Skins post in the editor and click Update. But the permalink is still not right.

    I will keep you posted and let you know if I need further help.

    Thanks so much for your time.

    Plugin Author ntm


    I’m glad the I could help.

    The only thing I don’t love about this new podPress is that the stats are based on the media file and in alphabetical order […]

    The Counts Only logging method logs only the downloads of the media files based only on the file name of the media files. That is why it is very important to use always unique names for the media files.
    But that is how podPress works at least since v8.8.

    To be more exact: podPress Counts Only saves also the IDs of the posts. But only the ID of a the post which was the first post which had a certain media file as an attachment. If you would add a media file with same name or the same media file to a further post then the Counts Only logging method would not count the downloads of this media file separately. It would add up the download numbers of the media file of second post to the downloads numbers of the media file of the first post. But it don’t saves the ID of the second post.
    That is why the stats of ep. 25 were not visible before. You have posted the episode 25 and people started to download the episode. The counter started to count the downloads and saved the ID of the first post together with the file name of ep. 25. But you re-posted the episode probably in a completely new post which has also a new and different ID and you have probably deleted the first post.
    For building Quick Counts table (in podPress v8.8.5.3) podPress takes the ID (of the first post) which has been stored with the download numbers and tries to find the corresponding post title in the wp_posts table of the db. But if you delete the first post then you delete it in the wp_posts table and podPress can’t find the title anymore. the result is that podPress does not display the download numbers of this media file in the Quick Counts table (but continues to count).

    Because of the fact that the Quick Counts table shows only faultless information if the podcast posts contain only one media file per post and each file has a unique name and if you do no re-posts, I have removed the Post and Publication Date column in the development version (and most likely in 8.8.6, too). This way the table will display only valid information.

    But I will think about a way to sort the media files by their publication date until the release of podPress 8.8.6.

    On one or the other way that is a bug of podPress and you helped to discover it. Thank you for your reports and that you have took the time to figure out the source of the problem.


    Hello Tim,

    Just wanted to give you an update that I was able to make that other fix in phpMyAdmin. Turns out I needed to go to wp_rhhi3j_posts because that is where my theme hides it.

    We shall see when I release the next podcast in September if the same issue arises. Hopefully all the work we have done has fixed it.

    Thanks again for your time. You have been a great help.



Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘[Plugin: podPress] Podpress Stats not showing up’ is closed to new replies.