Support » Plugin: podPress » [Plugin: podPress] Not working on Firefox browser

  • Sometime this week the PodPress player stopped working in Firefox. When I click play it gives the message “buffering” and does not change/play. I’ve tried with two different computers running FF and disabling any addons and the problem persists. I’ve seen conversations here about resolving such issues for Chrome but can only guess that this may work for FF. Anyone know for sure?

    http://wordpress.org/extend/plugins/podpress/

Viewing 15 replies - 16 through 30 (of 34 total)
  • Hello. I just installed podpress on my WP blog and the 1PixelOut player doesn’t show on neither Firefox, Chrome, nor Safari. I’d love to use the podpress 1PixelOut player on my post.

    When I activate “Use HTML5 tags” it shows the play button on Chrome and Safari, but not on Firefox. I also tried Nyetah .htaccess solution. It showed the player on Chrome and Safari almost on top of the download options, but still didn’t show on Firefox.

    Could you please help me?

    Podcast example: Embrocast

    I am using the Standard Theme.

    Any suggestion will be much appreciated. Thanks,

    Marcelo

    Plugin Author ntm

    (@ntm)

    @marcelo: Thank you for looking through older posts!!
    The problem in your case seems to be exactly the same as in JohnCDonahues case. A further plugin wraps all <object> elements into an additional <div> container element (<div class="fluid-width-video-wrapper" style=""> ... </div>). This disturbs the podPres script which loads the player.

    The question remains:
    Do you need the other plugin?
    What is the best way to keep the other plugin from wrapping the podPress objects? – Maybe there is a setting which makes exactly this. The class name fluid-width-video-wrapper lets me conclude that it has something to do with the with of flash videos.

    Maybe there is a further way. I going to think about a solution.

    Tim

    Thanks for the reply, Tim. I’ve removed all plugins but PodPress. Please let me know if you find any solution.

    Thanks,

    Marcelo

    Hi Tim,

    This is what I found when I looked for “fluid” on the Style of my theme:

    /* Post Format Video */

    .format-video .video-container, .fluid-width-video-wrapper {
    width: 100%;
    margin-left: 0 !important;
    margin-right: 0 !important;
    margin-bottom: 20px;
    }

    .format-video .entry-content {
    padding: 0;
    }

    .format-video .entry-content > * {
    margin-left: 20px;
    margin-right: 20px;
    }

    .format-video .entry-content *:first-child,
    .format-video .video-container,
    .format-video .fluid-width-video-wrapper {
    margin-left: 0;
    margin-right: 0;

    Any help or work-around?

    Thank you so much.

    Marcelo

    Plugin Author ntm

    (@ntm)

    Marcelo this is no CSS problem. A Javascript adds the additional <div> HTML elements dynamically to the code. This script is part of your theme – and not of a plugin. It is in the file /wp-content/themes/standard/js/lib/jquery.fitvids.js. (This file contains also some CSS definitions.)

    This file contains the line:

    if (this.tagName.toLowerCase() == 'embed' && $this.parent('object').length || $this.parent('.fluid-width-video-wrapper').length ) { return; }

    If you modify it to:

    if (this.tagName.toLowerCase() == 'embed' && $this.parent('object').length || $this.parent('.fluid-width-video-wrapper').length || $this.parent().hasClass('podpress_playerspace') ) { return; }

    then should help.

    Thanks for your attention, Tim. I’ve modified as you suggested, but is still not showing. Should I do anything else? Please help.

    Thanks again,

    Marcelo

    Plugin Author ntm

    (@ntm)

    Marcelo, the script modification is working. The script does not add the additional <div> element if the <object> or <embed> element is one of the podPress elements.

    But a further script is setting a huge values for the height of the player <object>s. That is why it still not visible.
    Maybe videopress.js does that. I will look into it.

    Plugin Author ntm

    (@ntm)

    Okay. The file /wp-content/themes/standard/jstheme.videopress.js contains some lines which adjusts the height of the <object> elements (which may be videos but can be flash audio players like the one of podPress) dynamically to the height of the post content height.
    But the podPress player <object>s have always a height of 24px.

    The lines 37-39 contain the code which is responsible:

    jQuery('object')
    	.attr('height', jQuery('.entry-content').height() + 'px')
    	.attr('width', jQuery('.entry-content').width() + 'px');

    Replace these lines with:

    var objects = jQuery('object');
    objects.each(function(i){
    	var $this = jQuery(this);
    	if ( $this.parent().hasClass('podpress_playerspace') ) {
    		$this.attr('width', jQuery('.entry-content').width() + 'px');
    		return;
    	}
    	$this.attr('height', jQuery('.entry-content').height() + 'px');
    });

    The new code will do the same as the old lines of code. But it will not modify the height of <object> elements inside the container element with the class podpress_playerspace.

    Notice: Every theme update would probably retrograde these modifications. That is why you should ask the support of your theme to create the possibility to exclude certain elements or classes of elements from the dynamic theme adjustment processes.

    It fixed the issue! THANK YOU!!!

    Question: Is it going to affect anything else or is it just an exception to exempt podpress?

    Thank you so much again!

    Plugin Author ntm

    (@ntm)

    Question: Is it going to affect anything else or is it just an exception to exempt podpress?

    The modifications are designed to affect only the podpress elements. These are adjustments to exclude only podPress elements from the Javascripts. They will not limit the scripts regarding any other elements like video which were not embedded with podPress.

    I am now having issues with my podpress plugin. The HTML5 player plays in Chrome & Safari, but podcasts plays in firefox and none play in IE9.

    Website: http://www.talkradiooone.com

    Any help would be appreciated.

    Plugin Author ntm

    (@ntm)

    @cjwelle:
    I visited the Talk Radio One blog and browsed through the Marc Germain Shows with the following browsers: Safari 5.1.5, Chrome 22.x, Opera 12.x, IE9 and also Firefox 16.0.1. I have no problem with the player(s). It worked in all the browsers. The blogs works.

    Since you are using a Cache plugin I guess that the problemsis a Cache issue. I’m not sure how you can resolve this. But maybe clearing the browser cache helps. There is probably also the possibility to clear the cache memory of the blog cache plugin.

    Thank you for your quick response. For some reason the MarcGermain Show posts are all working. Other podcasts are not currently. Only thing I can see differentiating them is the files are stored on another url, but these podcasts work under HTML5 players.

    I have emptied the caches as suggested and disabled the plugin to see if that would solve the issue as well, but no luck still.

    Plugin Author ntm

    (@ntm)

    For some reason the MarcGermain Show posts are all working. Other podcasts are not currently.

    I can observe this too.

    I downloaded the latest Film Fustians episode and added it to a post in my local test blog. Afterwards I tried play the episode with the 1PixelOut player in Firefox and the HTML5 audio player of the IE 9. The result is that both player played the episode -> it seems that the files are not the problem.
    I have also added the file with the URL of the original location (an URL of the file at your blog) to my local post. The problem occurs in this case. The player has problems playing this remote file.
    Since it is not a problem with the file itself, I guess that the problem is connected with the location of the files (the server and its configuration maybe).
    But I discovered a confusing thing. I switched off the HTML5 support in my blog so that the blog posts show always (in every browser) the flash player. I could observe that the flash player in IE8, IE9 and Chrome (22.x) did play the remote file. But Safari and Opera had a problem playing this file.

    I have no idea why this happens. I can only say that when I place one of your files on my server it plays in all browsers and players.
    That is why I still think that it has probably something to with the server configuration.
    Maybe you need to add mime-types of the mp3 files to the configuration file of the server (e.g. see http://search.cpan.org/~lds/Apache-MP3-4.00/MP3.pm#DESCRIPTION). But no expert for server configuration.

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘[Plugin: podPress] Not working on Firefox browser’ is closed to new replies.