Support » Plugin: podPress » [Plugin: podPress] iTunes stopped updating – answer in copyright characters?

  • Hello, In May iTunes stopped updating my podcast in their directory and I started getting mail from folks saying they weren’t getting the new eps via iTunes.

    Checked the feed against and everything looked fine there.

    Contacted iTunes and didn’t hear back until recently:


    When attempting to update your feed, we’re seeing the following error message:

    Error parsing feed: Invalid XML: Error on line 1: Content is not allowed in prolog.

    After using command ‘zap gremlins’ in BBEdit to identify any offending code, the following line item from your XML is highlighted:

    <copyright>Copyright © the crankcast 2012 </copyright>

    Please refer to our Tech Spec for common mistakes and proper named character entities:

    Once this has been corrected, please write in here and we’ll gladly review your feed.



    Looking at the link provided says that the correct value for the copyright symbol should be ” © ” .

    Does this make sense to anyone else? Nothing I know of changed between when it worked and when it didn’t.

    Should I track down the line that generates the symbol and change it to their recommendation?

    Which file contains that?

    iTunes link:

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ntm


    Hi Crank,

    the tech spec of Apple for podcast feeds says:

    […]The five characters above are the only characters that require escaping in XML. All other characters can be entered directly in an editor that supports UTF-8. You can also use numeric character references that specify the Unicode for the character[…]

    The copyright sign is not one of the critical characters and it is therefore not necessary to use the numeric character reference instead. Furthermore the spec says one can exchange e.g. copyright sign (and not need to have to exchange it).

    The well known feed validators or show also that it is totally correct not to escape the copyright sign.

    If Apple or iTunes requires now to escape this character then they should update the podcast specs.

    All in all I the hint to the line with the copyright note is wrong. Searching with a text editor (BBedit) for things which are not conform with XML specs is eventually not the best way. How has Maria-Elisa imported the XML code of the feed of your podcast into the editor? Via copy and paste?
    If one does that it is possible that the code which gets inserted in the editor is not UTF-8 encoded and was maybe already interpreted by the program which has been used to view the XML source code of the feed. This may lead to wrong result during the analysis for critical characters.

    Furthermore the error message

    Error parsing feed: Invalid XML: Error on line 1: Content is not allowed in prolog.

    points to a totally different problem which should also be detectable the feed validators. I would like to know which program or website displayed this error message and when. Does this error message still show up? If not, did you change something (maybe installed a new plugin or deactivated one)?

    If it is really necessary to change something in podPress, I will do this of course. But so far I’m not convinced that escaping the copyright sign would make a difference.
    The important thing is to find out where this error message occurs and why. Maybe you could ask this Elisa-Maria, too.


    Plugin Author ntm


    Hi Crank,

    a further thought: you are able the alter the text of the copyright section in the feeds. On the Feed/iTunes Settings page of podPress you can alter the copyright text.
    But as explained above modifying the copyright text will most likely not resolve the error regarding line 1.

    Thanks for the info.

    The odd thing is nothing changed between when it worked and when it didn’t, except for basic WP upgrades and Plugin upgrades, and I can’t seem to pinpoint anything that would interfere with the RSS feed.

    I suspect that it may be their tech-support not knowing the problem either and just grasping at things.

    thanks again,

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: podPress] iTunes stopped updating – answer in copyright characters?’ is closed to new replies.