Support » Plugins and Hacks » podPress » [Plugin: podPress] iTunes feed broken – stumped!

[Plugin: podPress] iTunes feed broken – stumped!

  • OK, I give up …. I’ve been googling for days, trying various things I found on this and other forums .. my son – a pro web developer – has tried too, and even he’s stumped!

    We recently redesigned my several years old website with WP. This involved moving my existing podcast data across. (same domain, same host). We used PP for this, and it worked – and iTunes picked up the feed too.

    Now a few months later … I’m having a break from podcasting so no new episodes since 2 months ago. Noticed that iTunes is returning an error trying to access my feed.

    feed URL could not be found on server

    feed URL is the same one I set up with back when we migrated to the new site. Back then feedvalidator said it was good. Now it gives a 404 error repeatedly. (But then below the 404 error message it successfully loads the channel data from the feed!!)

    I’ve tried enabling – disabling – reenabling the iTunes:new-feed-url thingy (with several days between). I’ve tried various feed formats (default – /feed/podcast .. /?feed=podcast .. /<page-permalink>/feed/ .. /<category-permalink>/feed/). All of them produce the same result in the validator.

    I also note that dropping the feed url into the address bar in Safari (mac) takes me to Mail (my default RSS reader), and then Mail gives me an error:

    Error No associated application could be found.

    I’ve even tried adding a 301 redirect from the old (pre-migration) .rss feed URL to the new one. (No idea whether that will achieve anything anyway … )

    Totally stumped. btw – despite knowing some of the geekspeak (extended self-learning … ) I’m actually a noob in this stuff. So please answer in normal speak, slowly.



Viewing 15 replies - 1 through 15 (of 46 total)
  • Plugin Author ntm


    A 404 error means usually that the URL is wrong respectively the feed URL does not work.
    Some programs (incl. the feed validator) may show you this error when the feed does not contain any posts and only the channel elements. This maybe the case if you try to use the http://.../?feed=podcast feed and have not attached the episodes with podPress to the posts. Or maybe this feed is not active (open the Feed/iTunes Settings page of podPress and go to the podPress Feeds section. Each of these additional feeds can be (de-)activated). It is also possible to change the name of the feed.
    Or maybe it has nothing to do with the podPress settings.

    It would be great if you could tell me the name of your blog or maybe the URL of the feed.

    About the iTunes:new-feed-url function:
    It is only recommended to use that setting in the old feed to point to the new feed URL. Both feeds have to active and valid at the time of the transition. Basically it works like this: the iTunes Store Server loads your podcast feed once a day. If you want to move the podcast blog then you install the new blog at the new location and activate the feature with the URL of the podcast feed of the new blog. When the iTS Server loads the (old) feed the next time it will recognise the new information and switch to the address of the feed of the new blog. If it has done this then any new changes in the old feed will have effect on the iTS Server.
    If you enable this feature in the new feed it may mislead the iTS Server.

    Thanks for the reply. In light of your later comments I’ve now disabled the new-feed-url thingy in podpress.

    I should have thought to provide my URLs before. Here they are:

    Front page: http://fullofgraceandtruth.net/
    Podcast page: http://fullofgraceandtruth.net/sermons/
    Podcast URL: http://fullofgraceandtruth.net/feed/podcast/

    (NB: there’s also a text blog with feed http://fullofgraceandtruth.net/feed/ )

    I’ve definitely attached the podcast episodes to the posts through podPress. And as I say, the same feed was working some weeks ago.

    Plugin Author ntm


    Thank you for posting the URL to your blog!

    It is interesting that I get only a blank page when open the feed URL in my browser.
    That could be a sign for a problem with the .htaccess file or a security plugin.
    Does the content of the file of your blog looks like described on this page: http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29 or does it contains additional (or less) lines of code?

    Do you use some kind of security plugin? Or a plugin which should optimize the URLs of your blog?

    I have also looked at the category feed of the post of the category Sermons:
    This feed works but it does not contain posts (only channel elements). One possible explanation for that is that your (or your helpers) have modified the default filter settings for this RSS feed. It is possible to limit the posts by the type of the media files. If you have done that and have chosen a file type other then .mp3 then it would explain this result.

    … or does it contains additional (or less) lines of code?

    It has all the code exactly as on your linked page.

    Above that it has:

    RewriteRule ^sermons/lancesermons.rss$ audio/lancesermons.rss [NC]
    RewriteRule ^audio/lancesermons.rss$ feed/podcast/ [NC,L,R=301]

    And then below the core bit:

    RewriteCond %{HTTP_HOST} ^fullofgraceandtruth\.net$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.fullofgraceandtruth\.net$
    RewriteRule ^sermons\/lancesermons\.rss$ "http\:\/\/fullofgraceandtruth\.net\/feed\/podcast\/" [R=301,L]

    Do you use some kind of security plugin?

    No active plugins for security – unless you’d count antispam etc.

    Or a plugin which should optimize the URLs of your blog?

    I don’t think so, although I’m not up on all the intricacies of the setup my geeky son created. I can ask him if you think that would help …

    … modified the default filter settings for this RSS feed. It is possible to limit the posts by the type of the media files. If you have done that and have chosen a file type other then .mp3 …

    Hmm … well that could be significant?? As a relative noob I’m rather bamboozled by all the array of settings in podpress. I do notice that I’ve selected two filetypes in the filetype filter: MP3 and M4A (no others). I don’t actually have any media files in the podcast other than MP3 at this point, but I think I added M4A to the selection on the assumption that that might happen in the future. Would that be a problem for the feed?

    Plugin Author ntm


    I’m no real expert for these RewriteRules. But I guess that one of those is probably the reason why the …/feed/podcast feed appears only as a blank page.
    All these additional rules have obviously the purpose to redirect request of the old podcast feed URL to the new one.
    But I’m not sure why the first rules redirects to audio/lancesermons.rss and the second redirects then to the new location. Furthermore it seems not right that the last three line should probably do the same as the first two RewriteRules.

    Please, ask the one who has implemented these lines whether both blocks are really necessary.

    I would suggest that you set a number sign (#) in front of those 5 lines (This character will deactivate the lines.) and try different rules:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_URI} (sermons\/lancesermons\.rss|audio\/lancesermons\.rss)$ [NC]
    RewriteRule . /feed/podcast/ [R=301,L]

    This RewriteCond and RewriteRule says basically that if a request URL ends with sermons/lancesermons.rss or audio/lancesermons.rss then redirect the request to the URL which consist of your web site and the pseudo folder /feed/podcast which is the address of your new podcast feed.

    Place the new lines below RewriteEngine On and before the rest of the podPress code.

    but I think I added M4A to the selection on the assumption that that might happen in the future. Would that be a problem for the feed?

    No. That is no problem. But did you control the right settings?
    The file type filter is in the settings of the category: Posts > Categpries > Edit Category . You can find on this page settings which look like the ones on Feed/iTunes Settings page. But they are only for a certain category.

    Thanks. I think it’s time to ask my son to hop aboard this thread and take over from here. My noob head hurts … 😉

    Stay tuned …

    Good news .. My son has found the problem. It was nothing to do with any of your lines of enquiry, ntm. (But huge thanks anyway 🙂

    I can’t give you the precise geekspeak, but apparently some file in the child theme had been mysteriously overwritten.

    Beats me …

    Anyway, all sweet now. (Only now having trouble getting the iTunes store to load the podcast .. But I guess that’s another subject?)

    Plugin Author ntm


    I’m glad that you could resolve the problem.

    Only now having trouble getting the iTunes store to load the podcast .. But I guess that’s another subject?

    Yes. Please, describe these difficulties in a new thread.


    I am having an issue validating the podcast feed in WordPress in the effort of getting the podcast submitted and live on iTunes.

    I have filled out all of the appropriate information in the Feed/iTunes settings page but once I submit to iTunes, it gives me an error: “Bad http result code: 404”

    Really been trying all I can to have this submitted successfully onto iTunes. We will be hosting podcast episodes on our server and uploading them weekly. Would appreciate a reply as soon as possible.

    Thank you!

    Plugin Author ntm


    Please open the Permalinks settings page of your blog and save the settings (don’t change them, simply save them again).

    If this does not then please tell me about the podcast feed. For instance it would be helpful for me to know the URL of this feed in question.

    Just saved the Permalinks settings on the page and it did not help anything.

    Here is the new feed URL we are trying to establish with iTunes that is in the settings of PodPress: http://music.ienlive.com/feed/podcast/

    Thank you for your support.

    Plugin Author ntm


    This is not working because this feed does not seem to exist or is not active.
    Please, control whether the feed exists and is active. Go to podPress Feed/iTunes Settings > Section podPress Feeds. The first feed in this section should have the slug name podcast. But the first first option for each is a checkbox where you can activate or deactivate the feed.
    Make sure that the feed is active and that it has the right slug name.
    If you need to activate it or to rename it then you need to save the Permalinks again.
    An URL which should work while the feed is active is this:

    Ok, I’ve gone ahead and renamed the slug from “livethemix” to “podcast.” Also went ahead and saved the settings and re-saved the Permalinks again. Not sure if that link is valid? Where do I turn from here?

    Thank you.

    Plugin Author ntm


    I’m not sure why the feed still seems to unavailable (404 error).
    One possibility is maybe that the feed does not contain posts. In such a case that error would occur.

    Have you added a podcast file with podPress to at least one of the posts?

    (It looks like you use a different plugin to display the media files in the posts.)

    Ok, that may be the problem. Just gone ahead and added an episode of the podcast via one of the posts and validated the feed, it looks to be validated and working!

    Could you please confirm this? Great to see it all coming together. We are looking to submit this successfully to iTunes ASAP.

    Thank you!

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘[Plugin: podPress] iTunes feed broken – stumped!’ is closed to new replies.