WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: podPress] Installing PodPress kills wordpress install

[Resolved] [Plugin: podPress] Installing PodPress kills wordpress install

  • At the activation of the plugin, Apache ramps up to 75% cpu usage, and wordpress site does not respond anymore.

    Removing plugin and restarting Apache eliminates the problem.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author ntm

    @ntm

    Hi,

    I have tried to reproduce that situation on my little test server. It is also not a very powerful machine. It is a VXL Itona TC4321 with 1GB RAM and a slow 4GB Compact Flash card as hard drive. The web server consists of XAMPP 1.7.4. The OS on the server is Debian 6.0.1 with the stable XFCE desktop.

    I have started XAMPP and the XFCE desktop to observe the CPU Graph and installed and activated podPress 8.8.10 via a different computer. This way the graph showed only the web server related activity.
    I could observe that the CPU usage was very high after the click on ‘Activate’. But only for 2-3 seconds. After that the CPU usage was almost zero or zero again.

    Although the list of changes seems maybe a little bit long, I would say that 8.8.10 is not that different compared to 8.8.9.2.
    But there is one thing that can cause more activity than during the upgrade from an older version to 8.8.9.2.
    8.8.10 renames all meta_keys of podPress entries in the postmeta db table. podPressMedia becomes _podPressMedia and podPressPostSpecific becomes _podPressPostSpecific. Depending on how much entries exist and on the power of your server, this procedure might take some seconds and this happens after you activate the plugin.

    Another thing which might slow down your server is eventually the new option “show HTML5 players always on page load” (player settings page). If it is activated then all visitors which are using the Safari, Chrome and IE 9 will see the HTML5 player of the browser for each MP3 file. Unfortunately the desktop versions of Safari and Chrome do not respect the preload="none" attribute and they will buffer all the files on the page. Because that behaviour might be problematic, this option is deactivated by default.

    If you can observe the CPU usage of your server then you are maybe allowed to modify the PHP settings. Control all time and memory limits. The podPress plugin is a relative big plugin and the .zip file is 4-5MB big. Extracting that file needs time too.

    Maybe it was a special situation on your server during the activation of the plugin.
    I have just released 8.8.10.1. Maybe you could try that version.

    Regards,
    Tim

    Hello Tim,

    I tried again with version 8.8.10.1 and everything went smoothly. As you said, I saw a spike during the activation (past the decompression stage) which quickly subsided.

    I am so grateful for your time, explanation and new release.

    podPress is truly a king among plugins, and it deserves more than five star.

    Thank you so much,

    George Zanardi

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: podPress] Installing PodPress kills wordpress install’ is closed to new replies.