Support » Plugin: podPress » [Plugin: podPress] Errors When Updating

  • Ever since I upgraded to 3.0 I have been getting the errors below when I update a post. I have tried a bunch of things to fix it including changing file permissions, deactivating and reactivating the & deleting the folder and re-uploading. Does anyone have any answers?

    Warning: mkdir() [function.mkdir]: No such file or directory in /public_html/wp-content/plugins/podpress/podpress_class.php on line 647

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/wp-content/plugins/podpress/podpress_class.php:647) in /home1/public_html/wp-includes/pluggable.php on line 890

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ntm


    Is your podPress version the version

    Please, create the folder wp-content/uploads/podpress_temp manually or check whether it exists or not. The permissions should be 755.


    Hey Tim,

    Thank you so much for getting back to me so quickly. I am currently using version and I created the folder wp-content/uploads/podpress_temp with the permissions set to 755. I still get the same error on update. I am currently look through the php files (but not modifying them) to see if there anything I can find that might be the issue.


    Plugin Author ntm


    Hi Ndlela,

    if you look into the podpress_class.php file you will see that the function checkWritableTempFileDir() checks whether this podpress_temp folder is in place and writeable.
    The error occurs in line 647 where it tries to create the folder which name should be stored in the variable $this->tempFileSystemPath. Usually this variable is not empty and by default just an absolute path which ends with …/wp-content/uploads/podpress_temp.
    Maybe the cause of this error message is because of a permissions problem.
    (The PHP manual on mkdir says […]When safe mode is enabled, PHP checks whether the directory in which the script is operating has the same UID (owner) as the script that is being executed.[…])
    Or maybe it is a value which mkdir cannot handle.
    It would be great if you could find out more about the content of this $this->tempFileSystemPath variable.
    I have written a little WP plugin for dumping the content of a PHP variable into a log file. It is called printphpnotices. You can download it from my website.
    Install it like other plugins, activate it and insert right after line 619 of the file podpress_class.php the call:


    After that update a post and look into the folder of this little debug plugin (/wp-content/plugins/aaaprintphpnotices). There should be a file called printphpnotices_log.dat which should contain the content of this variable.

    Besides this you could suppress the error message(s) if you would put an @ in front of the mkdir command.

    $mkdir = @mkdir($this->tempFileSystemPath);

    That should be ok because the function will return a custom error message if necessary or at least give back a matching result.
    But before you try this, try to retrieve the content of this variable.


    Plugin Author ntm


    BTW: the call of the checkWritableTempFileDir() function during updating a post is in line 1174 of podpress_admin_class.php

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: podPress] Errors When Updating’ is closed to new replies.